aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-08-14 03:23:38 +0200
committerMichał Polański <michal@polanski.me>2020-08-14 03:24:43 +0200
commit17b04d24124e933d747db0455457af766c8646b5 (patch)
tree41c2d52bb5b15eaa7dfcf00c8b852e58b43d1a4d
parent16656078060b23fc1728c3d251055f01e74b3ab8 (diff)
community/swaybg: use abuild-meson
-rw-r--r--community/swaybg/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/swaybg/APKBUILD b/community/swaybg/APKBUILD
index 67b45fc9897..d7d330120d0 100644
--- a/community/swaybg/APKBUILD
+++ b/community/swaybg/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=swaybg
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Wallpaper daemon for Wayland"
url="https://swaywm.org"
arch="all"
@@ -21,16 +21,14 @@ subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/swaybg/archive/$pkgver.tar.gz"
build() {
- meson \
- --prefix=/usr \
- --buildtype=plain \
+ abuild-meson \
-Dswaybg-version="$pkgver" \
- build
- ninja -C build
+ . output
+ meson compile -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="67d0e0109b906ece51800729182940374cc59fa07d0866b57cf876d12191fe12e796b84350a849dc85183fa58a3b2d196191e48dcc03dcc3708a980ed4a8cff0 swaybg-1.0.tar.gz"