aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-04-05 16:56:59 +0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-05 16:56:59 +0300
commit18a2b72720649baf4256a024fdb3e0608dbb1825 (patch)
tree9ee3c73d89743fc1cd70ff48e876110473845c7f
parent534f24d351a5865925156b823211eee61c4543e9 (diff)
testing/php7-xdebug: fix builddir and arch
-rw-r--r--testing/php7-xdebug/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/php7-xdebug/APKBUILD b/testing/php7-xdebug/APKBUILD
index b0f693d529c..891ef6a76f9 100644
--- a/testing/php7-xdebug/APKBUILD
+++ b/testing/php7-xdebug/APKBUILD
@@ -7,7 +7,7 @@ _pkgver=${pkgver/_rc/RC}
pkgrel=0
pkgdesc="PHP extension provides functions for function traces and profiling"
url="http://pecl.php.net/package/$_pkgreal"
-arch="x86_64 armhf"
+arch="all"
license="PHP"
depends=
pecldepends="php7-dev autoconf"
@@ -16,17 +16,17 @@ install=""
subpackages=""
source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
-_builddir="$srcdir"/$_pkgreal-$_pkgver
+builddir="$srcdir"/$_pkgreal-$_pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
phpize7 || return 1
./configure --prefix=/usr --with-php-config=php-config7 || return 1
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make INSTALL_ROOT="$pkgdir/" install || return 1
install -d "$pkgdir"/etc/php7/conf.d || return 1
echo "zend_extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini