aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2021-05-04 11:34:54 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2021-05-04 11:35:46 +0200
commit1923a99eb1e7dc4ee6b2d5231f558224ac993db8 (patch)
tree818e975c0eb08e06c8132f63866442f3a4343b3d
parent2b82abd40e0bf4d57119fdd1c1072e418ccf6ac2 (diff)
community/ncurses5: remove
nothing uses this anymore so it can be removed
-rw-r--r--community/ncurses5/APKBUILD72
-rw-r--r--community/ncurses5/ncurses-5.9-gcc-5.patch46
2 files changed, 0 insertions, 118 deletions
diff --git a/community/ncurses5/APKBUILD b/community/ncurses5/APKBUILD
deleted file mode 100644
index e6e207e1119..00000000000
--- a/community/ncurses5/APKBUILD
+++ /dev/null
@@ -1,72 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=ncurses5
-pkgver=5.9
-pkgrel=1
-pkgdesc="Console display library - ncurses5 compat"
-url="https://www.gnu.org/software/ncurses/"
-arch="all"
-license=MIT
-source="https://ftp.gnu.org/pub/gnu/ncurses/ncurses-$pkgver.tar.gz
- ncurses-5.9-gcc-5.patch
- "
-subpackages="$pkgname-widec-libs:widec $pkgname-libs"
-
-replaces="ncurses"
-builddir="$srcdir"/ncurses-$pkgver
-
-prepare() {
- default_prepare
- update_config_sub
-}
-
-build() {
- local _confopts="
- --build=$CBUILD
- --host=$CHOST
- --mandir=/usr/share/man
- --without-ada
- --disable-termcap
- --disable-rpath-hack
- --without-cxx-binding
- --with-terminfo-dirs=/etc/terminfo:/usr/share/terminfo
- --disable-pc-files
- --with-shared
- --without-static
- --without-progs"
- mkdir ncurses-build ncursesw-build
- cd ncurses-build
- ../configure $_confopts
- make libs
-
- cd ../ncursesw-build
- ../configure $_confopts \
- --enable-widec
- make libs
- cd ..
-}
-
-package() {
- make -j1 -C ncurses-build DESTDIR="$pkgdir" install.libs
- make -j1 -C ncursesw-build DESTDIR="$pkgdir" install.libs
- rm -r "$pkgdir"/usr/lib/*.a "$pkgdir"/usr/lib/*.so \
- "$pkgdir"/usr/include "$pkgdir"/usr/bin
-}
-
-widec() {
- pkgdesc="Ncurses wide character libraries - ncurses 5 compat"
- replaces="ncurses-widec-libs"
- depends="ncurses-terminfo-base"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/lib*w.so.* "$subpkgdir"/usr/lib/
-}
-
-libs() {
- pkgdesc="Ncurses5 libraries - ncurses 5 compat"
- depends="ncurses-terminfo-base"
- replaces="ncurses-libs"
- mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
-}
-
-sha512sums="d7c5e54b6d4d8b9211f0006ca8786f7609d180cc1aaebf4f25e7e35e12959779cf66447359a602daed625621ca32b0d910d67aef3eb8b6fdc3c373819a88faa1 ncurses-5.9.tar.gz
-200388ee1e8d8f656620d067e8993f79a50ed1a6ebee41ce8bd32b2a61cbe10c93347e2604229b58299c457640b247261a4d05afe60802dd4cce80d17bc2f10c ncurses-5.9-gcc-5.patch"
diff --git a/community/ncurses5/ncurses-5.9-gcc-5.patch b/community/ncurses5/ncurses-5.9-gcc-5.patch
deleted file mode 100644
index 2448229b88e..00000000000
--- a/community/ncurses5/ncurses-5.9-gcc-5.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-https://bugs.gentoo.org/545114
-
-extracted from the upstream change (which had many unrelated commits in one)
-
-From 97bb4678dc03e753290b39bbff30ba2825df9517 Mon Sep 17 00:00:00 2001
-From: "Thomas E. Dickey" <dickey@invisible-island.net>
-Date: Sun, 7 Dec 2014 03:10:09 +0000
-Subject: [PATCH] ncurses 5.9 - patch 20141206
-
-+ modify MKlib_gen.sh to work around change in development version of
- gcc introduced here:
- https://gcc.gnu.org/ml/gcc-patches/2014-06/msg02185.html
- https://gcc.gnu.org/ml/gcc-patches/2014-07/msg00236.html
- (reports by Marcus Shawcroft, Maohui Lei).
-
-diff --git a/ncurses/base/MKlib_gen.sh b/ncurses/base/MKlib_gen.sh
-index d8cc3c9..b91398c 100755
---- a/ncurses/base/MKlib_gen.sh
-+++ b/ncurses/base/MKlib_gen.sh
-@@ -474,11 +474,22 @@ sed -n -f $ED1 \
- -e 's/gen_$//' \
- -e 's/ / /g' >>$TMP
-
-+cat >$ED1 <<EOF
-+s/ / /g
-+s/^ //
-+s/ $//
-+s/P_NCURSES_BOOL/NCURSES_BOOL/g
-+EOF
-+
-+# A patch discussed here:
-+# https://gcc.gnu.org/ml/gcc-patches/2014-06/msg02185.html
-+# introduces spurious #line markers. Work around that by ignoring the system's
-+# attempt to define "bool" and using our own symbol here.
-+sed -e 's/bool/P_NCURSES_BOOL/g' $TMP > $ED2
-+cat $ED2 >$TMP
-+
- $preprocessor $TMP 2>/dev/null \
--| sed \
-- -e 's/ / /g' \
-- -e 's/^ //' \
-- -e 's/_Bool/NCURSES_BOOL/g' \
-+| sed -f $ED1 \
- | $AWK -f $AW2 \
- | sed -f $ED3 \
- | sed \