aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-08-09 10:22:54 +0200
committeralice <alice@ayaya.dev>2022-08-09 08:30:17 +0000
commit1c2274e052f1e3f1736ea95ca5cc4f5b1f31aef5 (patch)
tree6018a8be7b60ab717ec4d3e28814d82c9182292a
parent910f806e03d080d66eed52e543352f455b60112b (diff)
community/py3-k5test: add basic import test
-rw-r--r--community/py3-k5test/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/py3-k5test/APKBUILD b/community/py3-k5test/APKBUILD
index 123aef4086d..608bdc8e2f6 100644
--- a/community/py3-k5test/APKBUILD
+++ b/community/py3-k5test/APKBUILD
@@ -10,7 +10,6 @@ arch="noarch"
license="MIT"
depends="python3 krb5-dev krb5 krb5-server"
makedepends="py3-setuptools"
-options="!check" # Package doesn't have tests
source="https://files.pythonhosted.org/packages/source/k/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -18,6 +17,11 @@ build() {
python3 setup.py build
}
+check() {
+ # no upstream tests
+ PYTHONPATH=build/lib python3 -c "import k5test"
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}