aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2020-12-17 12:01:42 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-12-17 15:32:45 +0000
commit1c3365e688f8d1478c1fd529fa55d2131c4a0f88 (patch)
treeec46f58d6d149f525ad95f8fddebbb008643e6a4
parenta7f860dc9c6513ce94de4f71d6f3918169a19d19 (diff)
community/py3-fasteners: upgrade to 0.16
-rw-r--r--community/py3-fasteners/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/py3-fasteners/APKBUILD b/community/py3-fasteners/APKBUILD
index 82d3a567e4d..d3d37b57b25 100644
--- a/community/py3-fasteners/APKBUILD
+++ b/community/py3-fasteners/APKBUILD
@@ -1,30 +1,28 @@
# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=py3-fasteners
-pkgver=0.15
-pkgrel=2
+_pyname=fasteners
+pkgver=0.16
+pkgrel=0
pkgdesc="A python package that provides useful locks"
url="https://github.com/harlowja/fasteners/"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-monotonic py3-six"
makedepends="python3-dev py3-setuptools"
-source="fasteners-$pkgver.tar.gz::https://github.com/harlowja/fasteners/archive/$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/f/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/fasteners-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0c77c7061c8b76d0d018b07a3d33fc71701842f5b686456ebf31069694baa27a6cc47196267f24bc296078e7503ab0709fa28c9f0088c3cf777ea0e133bb5832 fasteners-0.15.tar.gz"
+sha512sums="aac91be8f732bcda238c40317359c7faaad632b26473eff940fef0c6c2c227cd83942122c0ec26da236ca8c19d3024798590244ec761c2d2700ffdc7142533da fasteners-0.16.tar.gz"