aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-14 23:31:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-15 01:26:54 -0300
commit1c7c96cae033c90973abef89b3b8acfbb580a8b1 (patch)
tree13086ce15c98ddf73ae5eca28971e0dff56ab2f2
parentd1c403c9439ec47617fca2290e510612d9b1d017 (diff)
community/wslay: use sphinx-build-3
-rw-r--r--community/wslay/APKBUILD9
-rw-r--r--community/wslay/py3.patch14
2 files changed, 20 insertions, 3 deletions
diff --git a/community/wslay/APKBUILD b/community/wslay/APKBUILD
index 190210a3604..80a5e7cbb0a 100644
--- a/community/wslay/APKBUILD
+++ b/community/wslay/APKBUILD
@@ -7,9 +7,11 @@ pkgdesc="The WebSocket library in C"
url="https://tatsuhiro-t.github.io/wslay/"
arch="all"
license="MIT"
-makedepends="autoconf automake libtool py-sphinx cunit-dev"
+makedepends="autoconf automake libtool py3-sphinx cunit-dev"
subpackages="$pkgname-doc $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tatsuhiro-t/wslay/archive/release-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tatsuhiro-t/wslay/archive/release-$pkgver.tar.gz
+ py3.patch
+ "
builddir="$srcdir"/$pkgname-release-$pkgver
prepare() {
@@ -32,4 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c50435d5b74ce3e817986f2a587cb86726f23545dde6d046a7d0f0bdfe0b4d236739d22c14d74b7e9b5a45e799bb94002c710b2724d0c31629ca41eeadad5749 wslay-1.1.0.tar.gz"
+sha512sums="c50435d5b74ce3e817986f2a587cb86726f23545dde6d046a7d0f0bdfe0b4d236739d22c14d74b7e9b5a45e799bb94002c710b2724d0c31629ca41eeadad5749 wslay-1.1.0.tar.gz
+efcb68370526598488cfadb23291eda0109bd53696468557c77073eb1782f1cb449cc0c60f01e806297c2895b42476cb143d2a6744e69e85d0204bd2a849afde py3.patch"
diff --git a/community/wslay/py3.patch b/community/wslay/py3.patch
new file mode 100644
index 00000000000..36000044460
--- /dev/null
+++ b/community/wslay/py3.patch
@@ -0,0 +1,14 @@
+diff --git a/configure.ac b/configure.ac
+index 5e83cbf..5cf44f1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -48,7 +48,7 @@ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ PKG_PROG_PKG_CONFIG([0.20])
+
+-AC_PATH_PROG([SPHINX_BUILD], [sphinx-build])
++AC_PATH_PROG([SPHINX_BUILD], [sphinx-build-3])
+ AC_SUBST([SPHINX_BUILD])
+ AM_CONDITIONAL([HAVE_SPHINX_BUILD], [ test "x$SPHINX_BUILD" != "x" ])
+
+