aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo L F Walbon <gwalbon@linux.ibm.com>2020-11-16 09:59:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-11-17 03:23:20 +0000
commit1ccc4c3b299ac93fc4c057dc47374909e8ec77b7 (patch)
tree54923a80e4801652883324376e47d8334e1adacc
parent0699392275ee44e20c6b7cf74895fe6e322f6640 (diff)
main/libjpeg-turbo: fix build under ppc64le
Altivec option doesn't work on pp64le. We hooked the gdb and it showed the altivec code failed in pp64le, so we decided to avoid this option on environment to fix in time for the next version of Alpine, 3.13. Signed-off-by: Gustavo L F Walbon <gwalbon@linux.ibm.com>
-rw-r--r--main/libjpeg-turbo/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/libjpeg-turbo/APKBUILD b/main/libjpeg-turbo/APKBUILD
index edd02814fa2..96ad2180a21 100644
--- a/main/libjpeg-turbo/APKBUILD
+++ b/main/libjpeg-turbo/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libjpeg-turbo
pkgver=2.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Accelerated baseline JPEG compression and decompression library"
url="https://libjpeg-turbo.org/"
arch="all"
@@ -33,6 +33,9 @@ build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
+ case "$CARCH" in
+ ppc64le) export JSIMD_FORCENONE=1;;
+ esac
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \