aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2023-04-18 21:54:14 +0200
committeralice <alice@ayaya.dev>2023-04-18 20:12:09 +0000
commit1da6d4b6a7d3b704b7f5b7ade2435e6a7f042acd (patch)
tree902e87085fe3d5aa501857851a56e227d1189deb
parent8373297fb2a4af8147045c9f8710a7328be86d35 (diff)
community/py3-b*: split -pyc
-rw-r--r--community/py3-babelfish/APKBUILD3
-rw-r--r--community/py3-backcall/APKBUILD3
-rw-r--r--community/py3-baron/APKBUILD3
-rw-r--r--community/py3-batalgorithm/APKBUILD3
-rw-r--r--community/py3-batinfo/APKBUILD3
-rw-r--r--community/py3-bayesian-optimization/APKBUILD3
-rw-r--r--community/py3-bbopt/APKBUILD3
-rw-r--r--community/py3-bcrypt/APKBUILD3
-rw-r--r--community/py3-beautifulsoup4/APKBUILD3
-rw-r--r--community/py3-beniget/APKBUILD3
-rw-r--r--community/py3-betamax/APKBUILD3
-rw-r--r--community/py3-betamax_matchers/APKBUILD3
-rw-r--r--community/py3-betamax_serializers/APKBUILD3
-rw-r--r--community/py3-binaryornot/APKBUILD3
-rw-r--r--community/py3-biopython/APKBUILD3
-rw-r--r--community/py3-bitstring/APKBUILD3
-rw-r--r--community/py3-bleach/APKBUILD3
-rw-r--r--community/py3-blessed/APKBUILD3
-rw-r--r--community/py3-blessings/APKBUILD3
-rw-r--r--community/py3-blinker/APKBUILD3
-rw-r--r--community/py3-blinkstick/APKBUILD4
-rw-r--r--community/py3-blist/APKBUILD3
-rw-r--r--community/py3-bluez/APKBUILD3
-rw-r--r--community/py3-boltons/APKBUILD3
-rw-r--r--community/py3-boolean.py/APKBUILD3
-rw-r--r--community/py3-booleanoperations/APKBUILD3
-rw-r--r--community/py3-boto3/APKBUILD3
-rw-r--r--community/py3-botocore/APKBUILD3
-rw-r--r--community/py3-bottle/APKBUILD3
-rw-r--r--community/py3-braceexpand/APKBUILD3
-rw-r--r--community/py3-bracex/APKBUILD3
-rw-r--r--community/py3-branca/APKBUILD3
-rw-r--r--community/py3-breathe/APKBUILD3
-rw-r--r--community/py3-brotlipy/APKBUILD3
-rw-r--r--community/py3-build/APKBUILD3
35 files changed, 70 insertions, 36 deletions
diff --git a/community/py3-babelfish/APKBUILD b/community/py3-babelfish/APKBUILD
index a1b9f828777..c020cdc582b 100644
--- a/community/py3-babelfish/APKBUILD
+++ b/community/py3-babelfish/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-babelfish
_pkgname=babelfish
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Work with countries and languages"
url="https://pypi.org/project/babelfish/"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-sphinx"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-backcall/APKBUILD b/community/py3-backcall/APKBUILD
index 1e361a3072b..bfc3bd013e8 100644
--- a/community/py3-backcall/APKBUILD
+++ b/community/py3-backcall/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-backcall
pkgver=0.2.0
-pkgrel=3
+pkgrel=4
pkgdesc="Backwards compatible callback APIs"
url="https://github.com/takluyver/backcall"
arch="noarch"
license="BSD-3-Clause"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/backcall/backcall-$pkgver.tar.gz"
builddir="$srcdir/${pkgname#py3-}-$pkgver"
diff --git a/community/py3-baron/APKBUILD b/community/py3-baron/APKBUILD
index e20dee43032..5e9e7a539af 100644
--- a/community/py3-baron/APKBUILD
+++ b/community/py3-baron/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Newbyte <newbyte@disroot.org>
pkgname=py3-baron
pkgver=0.10.1
-pkgrel=0
+pkgrel=1
pkgdesc="Full Syntax Tree for Python to make writing refactoring code a realist task"
url="https://github.com/PyCQA/baron"
arch="noarch"
@@ -10,6 +10,7 @@ license="LGPL-3.0-or-later"
depends="python3 py3-rply"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/baron/baron-$pkgver.tar.gz"
builddir="$srcdir/baron-$pkgver"
diff --git a/community/py3-batalgorithm/APKBUILD b/community/py3-batalgorithm/APKBUILD
index 4390e897125..69125acd44b 100644
--- a/community/py3-batalgorithm/APKBUILD
+++ b/community/py3-batalgorithm/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-batalgorithm
_pkgorig=BatAlgorithm
pkgver=0.3.1
-pkgrel=3
+pkgrel=4
pkgdesc="Implementation of bat-inspired metaheuristic algorithm"
url="https://github.com/buma/BatAlgorithm"
arch="noarch"
license="MIT"
depends="python3 py3-numpy"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/B/BatAlgorithm/BatAlgorithm-$pkgver.tar.gz"
builddir="$srcdir/$_pkgorig-$pkgver"
diff --git a/community/py3-batinfo/APKBUILD b/community/py3-batinfo/APKBUILD
index 6472519c276..50bbbb66996 100644
--- a/community/py3-batinfo/APKBUILD
+++ b/community/py3-batinfo/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-batinfo
_pkgname=batinfo
pkgver=0.4.2
-pkgrel=7
+pkgrel=8
pkgdesc="Simple Python3 lib to retreive battery information"
options="!check" # No testsuite
url="https://github.com/nicolargo/batinfo"
@@ -11,6 +11,7 @@ arch="noarch"
license="LGPL-3.0-or-later"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-bayesian-optimization/APKBUILD b/community/py3-bayesian-optimization/APKBUILD
index 9a75463a4f5..0382d5551e4 100644
--- a/community/py3-bayesian-optimization/APKBUILD
+++ b/community/py3-bayesian-optimization/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-bayesian-optimization
pkgver=1.4.2
-pkgrel=0
+pkgrel=1
pkgdesc="A Python implementation of global optimization with gaussian processes"
url="https://github.com/fmfn/BayesianOptimization"
arch="noarch !s390x" #py3-scikit-learn
@@ -10,6 +10,7 @@ license="MIT"
depends="python3 py3-colorama py3-numpy py3-scipy py3-scikit-learn"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://github.com/fmfn/BayesianOptimization/archive/v$pkgver/bayesian-optimization-$pkgver.tar.gz"
builddir="$srcdir/BayesianOptimization-$pkgver"
diff --git a/community/py3-bbopt/APKBUILD b/community/py3-bbopt/APKBUILD
index 6353c359775..ea15a330b80 100644
--- a/community/py3-bbopt/APKBUILD
+++ b/community/py3-bbopt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-bbopt
pkgver=1.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Black box hyperparameter optimization made easy"
url="https://github.com/evhub/bbopt"
arch="noarch !s390x" # blocked by py3-scikit-optimize
@@ -16,6 +16,7 @@ depends="
"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/b/bbopt/bbopt-$pkgver.tar.gz"
options="!check" # Requires unpackaged coconut
builddir="$srcdir/bbopt-$pkgver"
diff --git a/community/py3-bcrypt/APKBUILD b/community/py3-bcrypt/APKBUILD
index 0d3f2d6e0a2..e2fd47f77e7 100644
--- a/community/py3-bcrypt/APKBUILD
+++ b/community/py3-bcrypt/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-bcrypt
_pkgname=bcrypt
pkgver=4.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Modern password hashing for your software and your servers"
url="https://github.com/pyca/bcrypt"
arch="all"
@@ -20,6 +20,7 @@ makedepends="
"
checkdepends="py3-pytest"
options="net"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/pyca/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-beautifulsoup4/APKBUILD b/community/py3-beautifulsoup4/APKBUILD
index 656ee1f566a..db6b7f871ea 100644
--- a/community/py3-beautifulsoup4/APKBUILD
+++ b/community/py3-beautifulsoup4/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-beautifulsoup4
_pkgname=beautifulsoup4
pkgver=4.12.2
-pkgrel=0
+pkgrel=1
pkgdesc="A Python HTML/XML parser"
url="https://www.crummy.com/software/BeautifulSoup/index.html"
arch="noarch"
@@ -14,6 +14,7 @@ makedepends="
py3-hatchling
"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/beautifulsoup4/beautifulsoup4-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-beniget/APKBUILD b/community/py3-beniget/APKBUILD
index 3c96baec6d8..0cddcd3bb8a 100644
--- a/community/py3-beniget/APKBUILD
+++ b/community/py3-beniget/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=py3-beniget
pkgver=0.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Extract semantic information about static Python code"
url="https://github.com/serge-sans-paille/beniget"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-gast"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/serge-sans-paille/beniget/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/beniget-$pkgver"
diff --git a/community/py3-betamax/APKBUILD b/community/py3-betamax/APKBUILD
index 60b95e2cea6..b67b010869a 100644
--- a/community/py3-betamax/APKBUILD
+++ b/community/py3-betamax/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-betamax
pkgver=0.8.1
-pkgrel=4
+pkgrel=5
pkgdesc="VCR imitation designed only for python-requests"
options="!check" # 3 Tests fail, tests require internet
url="https://github.com/betamaxpy/betamax"
@@ -9,6 +9,7 @@ arch="noarch"
license="Apache-2.0"
depends="python3 py3-requests"
makedepends="py3-setuptools py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/betamaxpy/betamax/archive/$pkgver.tar.gz
https://github.com/betamaxpy/betamax/commit/165cc321f2b9839418269e9493b03eb2e43f7ddf.patch
tests-disable-broken-assertion.patch
diff --git a/community/py3-betamax_matchers/APKBUILD b/community/py3-betamax_matchers/APKBUILD
index 77d587080b9..185572b962c 100644
--- a/community/py3-betamax_matchers/APKBUILD
+++ b/community/py3-betamax_matchers/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-betamax_matchers
pkgver=0.4.0
-pkgrel=3
+pkgrel=4
pkgdesc="A group of experimental matchers for Betamax"
url="https://github.com/betamaxpy/betamax_matchers"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-betamax py3-requests-toolbelt"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/betamaxpy/betamax_matchers/archive/$pkgver.tar.gz"
builddir="$srcdir/betamax_matchers-$pkgver"
diff --git a/community/py3-betamax_serializers/APKBUILD b/community/py3-betamax_serializers/APKBUILD
index e25dd20c829..0a21df2b756 100644
--- a/community/py3-betamax_serializers/APKBUILD
+++ b/community/py3-betamax_serializers/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-betamax_serializers
pkgver=0.2.1
-pkgrel=4
+pkgrel=5
pkgdesc="A collection of serializers that may eventually be included in betamax"
url="https://gitlab.com/betamax/serializers"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-yaml py3-betamax"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://gitlab.com/betamax/serializers/-/archive/$pkgver/serializers-$pkgver.tar.gz"
builddir="$srcdir/serializers-$pkgver"
diff --git a/community/py3-binaryornot/APKBUILD b/community/py3-binaryornot/APKBUILD
index 15f9f25b08b..7be4c07abe0 100644
--- a/community/py3-binaryornot/APKBUILD
+++ b/community/py3-binaryornot/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-binaryornot
_commit=360d7aeefeccf6b5359ac4dab8d7b6411d33ec08
pkgver=0.4.4
-pkgrel=2
+pkgrel=3
pkgdesc="Python package to check if a file is binary or text"
url="https://github.com/audreyr/binaryornot"
arch="noarch"
@@ -11,6 +11,7 @@ license="BSD-3-Clause"
depends="python3 py3-chardet"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-hypothesis"
+subpackages="$pkgname-pyc"
source="https://github.com/audreyfeldroy/binaryornot/archive/$_commit.tar.gz"
builddir="$srcdir/binaryornot-$_commit"
diff --git a/community/py3-biopython/APKBUILD b/community/py3-biopython/APKBUILD
index e75e51b5e87..c4f74879f11 100644
--- a/community/py3-biopython/APKBUILD
+++ b/community/py3-biopython/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Charles Pritchard <chuck@jumis.com>
pkgname=py3-biopython
pkgver=1.81
-pkgrel=0
+pkgrel=1
pkgdesc="Python tools for computational molecular biology."
options="!check" # test_NCBI_qblast hangs
url="https://biopython.org/"
@@ -10,6 +10,7 @@ arch="all"
license="BSD-3-Clause"
depends="py3-numpy python3"
makedepends="py3-setuptools py3-numpy-dev python3-dev"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/biopython/biopython-$pkgver.tar.gz"
builddir="$srcdir/biopython-$pkgver"
diff --git a/community/py3-bitstring/APKBUILD b/community/py3-bitstring/APKBUILD
index f105ee38444..511db070e39 100644
--- a/community/py3-bitstring/APKBUILD
+++ b/community/py3-bitstring/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Michał Adamski <michal@ert.pl>
pkgname=py3-bitstring
pkgver=4.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Simple construction, analysis and modification of binary data"
url="https://github.com/scott-griffiths/bitstring"
license="MIT"
arch="noarch"
depends="python3"
makedepends="py3-gpep517 py3-installer py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://github.com/scott-griffiths/bitstring/archive/bitstring-$pkgver/py3-bitstring-$pkgver.tar.gz"
builddir="$srcdir/bitstring-bitstring-$pkgver"
diff --git a/community/py3-bleach/APKBUILD b/community/py3-bleach/APKBUILD
index 6347636eb16..8cf3901d409 100644
--- a/community/py3-bleach/APKBUILD
+++ b/community/py3-bleach/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=py3-bleach
pkgver=5.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="whitelist-based HTML sanitizing library"
url="https://github.com/mozilla/bleach"
arch="noarch"
@@ -10,6 +10,7 @@ license="Apache-2.0"
depends="python3 py3-html5lib"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/b/bleach/bleach-$pkgver.tar.gz
0002-no_vendored_html5lib.patch
"
diff --git a/community/py3-blessed/APKBUILD b/community/py3-blessed/APKBUILD
index 3869e5bd86d..b331b3198d1 100644
--- a/community/py3-blessed/APKBUILD
+++ b/community/py3-blessed/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=py3-blessed
pkgver=1.20.0
-pkgrel=0
+pkgrel=1
pkgdesc="Easy, practical library for making terminal apps"
options="!check" # Some tests fail
url="https://pypi.org/project/blessed/"
@@ -11,6 +11,7 @@ license="MIT"
depends="python3 py3-wcwidth py3-six"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-mock ncurses"
+subpackages="$pkgname-pyc"
source="https://pypi.io/packages/source/b/blessed/blessed-$pkgver.tar.gz"
builddir="$srcdir/blessed-$pkgver"
diff --git a/community/py3-blessings/APKBUILD b/community/py3-blessings/APKBUILD
index 6940904149e..5d648dd07b5 100644
--- a/community/py3-blessings/APKBUILD
+++ b/community/py3-blessings/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-blessings
_pkgname=blessings
pkgver=1.7
-pkgrel=8
+pkgrel=9
pkgdesc="Python library for terminal coloring, styling and positioning"
url="https://github.com/erikrose/blessings"
arch="noarch"
@@ -11,6 +11,7 @@ license="MIT"
depends="py3-six"
makedepends="py3-setuptools"
options="!check" # tests require a real terminal
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-blinker/APKBUILD b/community/py3-blinker/APKBUILD
index 3a81f42606a..e32a5959263 100644
--- a/community/py3-blinker/APKBUILD
+++ b/community/py3-blinker/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-blinker
_pkgname=blinker
pkgver=1.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, simple object-to-object and broadcast signalling"
url="https://pypi.org/project/blinker"
arch="noarch"
@@ -11,6 +11,7 @@ license="MIT"
depends="python3"
makedepends="py3-setuptools py3-gpep517 py3-wheel py3-installer"
checkdepends="py3-pytest py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
diff --git a/community/py3-blinkstick/APKBUILD b/community/py3-blinkstick/APKBUILD
index 05a581326f4..bea6ea1a935 100644
--- a/community/py3-blinkstick/APKBUILD
+++ b/community/py3-blinkstick/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-blinkstick
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
_commit="60bd10528fe6ecabfdaef4c5343864e98de19263" # Git repo isn't tagged, but this is equivalent to 1.2.0 on PyPi
pkgdesc="Python interface to control BlinkStick devices connected to the computer"
url="https://www.blinkstick.com/"
@@ -13,7 +13,7 @@ depends="
python3
"
makedepends="py3-setuptools"
-subpackages="blinkstick"
+subpackages="blinkstick $pkgname-pyc"
# https://pypi.python.org/packages/source/B/BlinkStick/BlinkStick-$pkgver.tar.gz
source="https://github.com/arvydas/blinkstick-python/archive/$_commit/blinkstick-python-$_commit.tar.gz
0001-python3-env.patch
diff --git a/community/py3-blist/APKBUILD b/community/py3-blist/APKBUILD
index 2dcda6f6776..80e4ea52068 100644
--- a/community/py3-blist/APKBUILD
+++ b/community/py3-blist/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-blist
_pkgname=blist
pkgver=1.3.6
-pkgrel=7
+pkgrel=8
pkgdesc="A list-like type with better asymptotic performance and similar performance on small lists"
url="https://github.com/DanielStutzbach/blist"
arch="all"
license="BSD-3-Clause"
depends="python3"
makedepends="python3-dev py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/DanielStutzbach/blist/archive/v$pkgver.tar.gz
0004-compatibility-with-PEP-620.patch
fix-python3.7.patch
diff --git a/community/py3-bluez/APKBUILD b/community/py3-bluez/APKBUILD
index 7496a4442f2..d3b531c7498 100644
--- a/community/py3-bluez/APKBUILD
+++ b/community/py3-bluez/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-bluez
_pkgname=pybluez
pkgver=0.23
-pkgrel=5
+pkgrel=6
pkgdesc="Python API for the BlueZ bluetooth stack"
url="https://github.com/pybluez/pybluez"
arch="all"
@@ -11,6 +11,7 @@ license="GPL-2.0-or-later"
makedepends="python3-dev py3-setuptools bluez-dev"
checkdepends="py3-pytest"
options="!check"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgname/$_pkgname/archive/$pkgver.tar.gz
setuptools59.patch
py3.11.patch
diff --git a/community/py3-boltons/APKBUILD b/community/py3-boltons/APKBUILD
index 0aa2b095041..24388f47fea 100644
--- a/community/py3-boltons/APKBUILD
+++ b/community/py3-boltons/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=py3-boltons
pkgver=23.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Bolted-on functionality for python3"
url="https://github.com/mahmoud/boltons"
arch="noarch"
@@ -14,6 +14,7 @@ makedepends="
py3-wheel
"
checkdepends="py3-pytest-xdist py3-pytest-cov"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver-2.tar.gz::https://github.com/mahmoud/boltons/archive/$pkgver.tar.gz"
builddir="$srcdir/boltons-$pkgver"
diff --git a/community/py3-boolean.py/APKBUILD b/community/py3-boolean.py/APKBUILD
index 0c3e7f01574..be6a6b1e2ab 100644
--- a/community/py3-boolean.py/APKBUILD
+++ b/community/py3-boolean.py/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-boolean.py
_pkgname=boolean.py
pkgver=4.0
-pkgrel=2
+pkgrel=3
pkgdesc="Define boolean algebras, create and parse boolean expressions and DSL"
url="https://github.com/bastikr/boolean.py"
arch="noarch"
@@ -11,6 +11,7 @@ license="BSD-2-Clause"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-booleanoperations/APKBUILD b/community/py3-booleanoperations/APKBUILD
index 09d27ade658..42fd4555c63 100644
--- a/community/py3-booleanoperations/APKBUILD
+++ b/community/py3-booleanoperations/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-booleanoperations
_pkgname=booleanOperations
pkgver=0.9.0
-pkgrel=3
+pkgrel=4
pkgdesc="Boolean operations on paths"
options="!check" # Requires unpackaged 'FontPens'
url="https://github.com/typemytype/booleanOperations"
@@ -11,6 +11,7 @@ arch="noarch"
license="MIT"
depends="python3 py3-pyclipper py3-fonttools"
makedepends="py3-setuptools py3-setuptools_scm py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.zip"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-boto3/APKBUILD b/community/py3-boto3/APKBUILD
index b987bb64206..dd0546ae6eb 100644
--- a/community/py3-boto3/APKBUILD
+++ b/community/py3-boto3/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=py3-boto3
pkgver=1.26.108
-pkgrel=0
+pkgrel=1
pkgdesc="AWS SDK for Python (Boto3)"
url="https://aws.amazon.com/sdk-for-python/"
license="Apache-2.0"
@@ -18,6 +18,7 @@ makedepends="
py3-setuptools
py3-wheel
"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/boto3/boto3-$pkgver.tar.gz"
builddir="$srcdir"/boto3-$pkgver
options="!check" # take way too long
diff --git a/community/py3-botocore/APKBUILD b/community/py3-botocore/APKBUILD
index bc4834c0a42..afa4b51f256 100644
--- a/community/py3-botocore/APKBUILD
+++ b/community/py3-botocore/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-botocore
# Verify required version from py3-boto3 on this package before upgrading
pkgver=1.29.108
-pkgrel=0
+pkgrel=1
pkgdesc="The low-level, core functionality of Boto3"
url="https://github.com/boto/botocore"
arch="noarch"
@@ -20,6 +20,7 @@ makedepends="
py3-setuptools
py3-wheel
"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/botocore/botocore-$pkgver.tar.gz"
builddir="$srcdir/botocore-$pkgver"
options="!check" # take way too long
diff --git a/community/py3-bottle/APKBUILD b/community/py3-bottle/APKBUILD
index b65871a884a..50271961354 100644
--- a/community/py3-bottle/APKBUILD
+++ b/community/py3-bottle/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-bottle
_pkgname=bottle
pkgver=0.12.25
-pkgrel=0
+pkgrel=1
pkgdesc="fast, simple and lightweight WSGI micro web-framework"
options="!check" # failures=1
url="https://bottlepy.org/docs/dev"
@@ -15,6 +15,7 @@ makedepends="
py3-setuptools
py3-wheel
"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-braceexpand/APKBUILD b/community/py3-braceexpand/APKBUILD
index 5d538234572..26982a14800 100644
--- a/community/py3-braceexpand/APKBUILD
+++ b/community/py3-braceexpand/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=py3-braceexpand
pkgver=0.1.7
-pkgrel=2
+pkgrel=3
pkgdesc="Bash-style brace expansion for Python"
url="https://github.com/trendels/braceexpand"
arch="noarch"
@@ -12,6 +12,7 @@ depends="
py3-pytest
"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://github.com/trendels/braceexpand/archive/v$pkgver/braceexpand-v$pkgver.tar.gz"
builddir="$srcdir/braceexpand-$pkgver"
diff --git a/community/py3-bracex/APKBUILD b/community/py3-bracex/APKBUILD
index 94d12b1756e..877a06fabe0 100644
--- a/community/py3-bracex/APKBUILD
+++ b/community/py3-bracex/APKBUILD
@@ -2,7 +2,7 @@
pkgname=py3-bracex
_pkgname=bracex
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="brace expanding library (à la Bash) for Python"
url="https://facelessuser.github.io/bracex/"
arch="noarch"
@@ -10,6 +10,7 @@ license="MIT"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
diff --git a/community/py3-branca/APKBUILD b/community/py3-branca/APKBUILD
index 504f44ddb29..a982ff536be 100644
--- a/community/py3-branca/APKBUILD
+++ b/community/py3-branca/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-branca
_pkgorig=branca
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="Generate complex HTML+JS pages with Python"
url="https://github.com/python-visualization/branca"
arch="noarch"
@@ -16,6 +16,7 @@ makedepends="
py3-wheel
"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://github.com/python-visualization/branca/archive/v$pkgver/$_pkgorig-$pkgver.tar.gz"
builddir="$srcdir/$_pkgorig-$pkgver"
options="!check" # disable for now - several test dependencies are missing
diff --git a/community/py3-breathe/APKBUILD b/community/py3-breathe/APKBUILD
index ac2411885c4..c06462565ca 100644
--- a/community/py3-breathe/APKBUILD
+++ b/community/py3-breathe/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-breathe
_pkgname=breathe
pkgver=4.35.0
-pkgrel=0
+pkgrel=1
pkgdesc="ReStructuredText and Sphinx bridge to Doxygen"
url="https://breathe.readthedocs.org/"
arch="noarch"
@@ -14,6 +14,7 @@ makedepends="py3-gpep517
py3-wheel
"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/breathe-doc/breathe/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
diff --git a/community/py3-brotlipy/APKBUILD b/community/py3-brotlipy/APKBUILD
index 48fb430a391..9e31be1396c 100644
--- a/community/py3-brotlipy/APKBUILD
+++ b/community/py3-brotlipy/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-brotlipy
_pkgname=brotlipy
pkgver=0.7.0
-pkgrel=4
+pkgrel=5
pkgdesc="Python bindings for the Brotli compression library"
options="!check" # Tests fail with new pytest
url="https://github.com/python-hyper/brotlicffi"
@@ -12,6 +12,7 @@ license="MIT"
depends="python3"
makedepends="py3-setuptools python3-dev py3-cffi"
checkdepends="py3-pytest py3-hypothesis py3-pytest-runner"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/brotlipy-$pkgver"
diff --git a/community/py3-build/APKBUILD b/community/py3-build/APKBUILD
index eb48e10cbac..2cab51ad447 100644
--- a/community/py3-build/APKBUILD
+++ b/community/py3-build/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-build
_pkgname=build
pkgver=0.10.0
-pkgrel=0
+pkgrel=1
pkgdesc="Correct PEP517 package builder"
url="https://github.com/pypa/build"
arch="noarch"
license="MIT"
depends="python3 py3-packaging py3-pyproject-hooks"
makedepends="py3-wheel py3-flit-core py3-gpep517 py3-installer py3-pyproject-hooks"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver