aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-08-22 13:41:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2022-08-22 13:44:34 +0200
commit1df69604c49fe189142f99bcd242f679b4feba40 (patch)
tree9955f7928b110f504abfe23fc6f54fdd0b3f8ac3
parent8116a127ece549f7af2e6de1bf45a035469c5f5e (diff)
community/alpine-make-rootfs: backport fixes
-rw-r--r--community/alpine-make-rootfs/APKBUILD13
-rw-r--r--community/alpine-make-rootfs/add-new-signing-key-for-x86_64.patch23
-rw-r--r--community/alpine-make-rootfs/fix-missing-release-files-on-edge.patch39
3 files changed, 72 insertions, 3 deletions
diff --git a/community/alpine-make-rootfs/APKBUILD b/community/alpine-make-rootfs/APKBUILD
index 1914a65b319..9aaf8dd7627 100644
--- a/community/alpine-make-rootfs/APKBUILD
+++ b/community/alpine-make-rootfs/APKBUILD
@@ -2,13 +2,16 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=alpine-make-rootfs
pkgver=0.5.1
-pkgrel=0
+pkgrel=1
pkgdesc="Make customized Alpine Linux rootfs (base image) for containers"
url="https://github.com/alpinelinux/alpine-make-rootfs"
arch="noarch"
license="MIT"
depends="tar"
-source="$pkgname-$pkgver.tar.gz::https://github.com/alpinelinux/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/alpinelinux/$pkgname/archive/v$pkgver.tar.gz
+ add-new-signing-key-for-x86_64.patch
+ fix-missing-release-files-on-edge.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
options="!check" # no suitable tests provided
@@ -17,4 +20,8 @@ package() {
make install DESTDIR="$pkgdir" PREFIX=/usr
}
-sha512sums="d2c98c3fc69b4f61d798714711b668da7abafb111846a0a8d4cbcf1003a2b677a18ad9cfa3565a0f2cb0a74a2f30f485786310a8e09ff942037bf60d88bf3245 alpine-make-rootfs-0.5.1.tar.gz"
+sha512sums="
+d2c98c3fc69b4f61d798714711b668da7abafb111846a0a8d4cbcf1003a2b677a18ad9cfa3565a0f2cb0a74a2f30f485786310a8e09ff942037bf60d88bf3245 alpine-make-rootfs-0.5.1.tar.gz
+b1e42986e889f8924e46b08d4ca614f965b9a8d4e5bf4271f9901fffd9fe022b3930537ec8d0f17ca9cea77050b4a031e61eb26636e759a5587c9c0b4d2cc160 add-new-signing-key-for-x86_64.patch
+5d46180968bd5d01c5235a5fe0d17d3f8949ab4ba6c4a69eb0e67fdc8f23563d7030e9bd1ad7ef231322b05e6518ec48b45628bb0496339829548c5028828174 fix-missing-release-files-on-edge.patch
+"
diff --git a/community/alpine-make-rootfs/add-new-signing-key-for-x86_64.patch b/community/alpine-make-rootfs/add-new-signing-key-for-x86_64.patch
new file mode 100644
index 00000000000..2e94cd1b1a8
--- /dev/null
+++ b/community/alpine-make-rootfs/add-new-signing-key-for-x86_64.patch
@@ -0,0 +1,23 @@
+Patch-Source: https://github.com/alpinelinux/alpine-make-rootfs/commit/64a89ab6973c3a60a975243bc2086d6743c50aae
+--
+From 64a89ab6973c3a60a975243bc2086d6743c50aae Mon Sep 17 00:00:00 2001
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sun, 14 Nov 2021 00:04:21 +0100
+Subject: [PATCH] Add new package signing key for x86_64
+
+---
+ alpine-make-rootfs | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/alpine-make-rootfs b/alpine-make-rootfs
+index 0d033ff..56c99e3 100755
+--- a/alpine-make-rootfs
++++ b/alpine-make-rootfs
+@@ -101,6 +101,7 @@ readonly ALPINE_BASE_PKGS='alpine-baselayout busybox busybox-suid musl-utils'
+ readonly ALPINE_KEYS='
+ alpine-devel@lists.alpinelinux.org-4a6a0840.rsa.pub:MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA1yHJxQgsHQREclQu4Ohe\nqxTxd1tHcNnvnQTu/UrTky8wWvgXT+jpveroeWWnzmsYlDI93eLI2ORakxb3gA2O\nQ0Ry4ws8vhaxLQGC74uQR5+/yYrLuTKydFzuPaS1dK19qJPXB8GMdmFOijnXX4SA\njixuHLe1WW7kZVtjL7nufvpXkWBGjsfrvskdNA/5MfxAeBbqPgaq0QMEfxMAn6/R\nL5kNepi/Vr4S39Xvf2DzWkTLEK8pcnjNkt9/aafhWqFVW7m3HCAII6h/qlQNQKSo\nGuH34Q8GsFG30izUENV9avY7hSLq7nggsvknlNBZtFUcmGoQrtx3FmyYsIC8/R+B\nywIDAQAB
+ alpine-devel@lists.alpinelinux.org-5261cecb.rsa.pub:MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAwlzMkl7b5PBdfMzGdCT0\ncGloRr5xGgVmsdq5EtJvFkFAiN8Ac9MCFy/vAFmS8/7ZaGOXoCDWbYVLTLOO2qtX\nyHRl+7fJVh2N6qrDDFPmdgCi8NaE+3rITWXGrrQ1spJ0B6HIzTDNEjRKnD4xyg4j\ng01FMcJTU6E+V2JBY45CKN9dWr1JDM/nei/Pf0byBJlMp/mSSfjodykmz4Oe13xB\nCa1WTwgFykKYthoLGYrmo+LKIGpMoeEbY1kuUe04UiDe47l6Oggwnl+8XD1MeRWY\nsWgj8sF4dTcSfCMavK4zHRFFQbGp/YFJ/Ww6U9lA3Vq0wyEI6MCMQnoSMFwrbgZw\nwwIDAQAB
++alpine-devel@lists.alpinelinux.org-6165ee59.rsa.pub:MIICIjANBgkqhkiG9w0BAQEFAAOCAg8AMIICCgKCAgEAutQkua2CAig4VFSJ7v54\nALyu/J1WB3oni7qwCZD3veURw7HxpNAj9hR+S5N/pNeZgubQvJWyaPuQDm7PTs1+\ntFGiYNfAsiibX6Rv0wci3M+z2XEVAeR9Vzg6v4qoofDyoTbovn2LztaNEjTkB+oK\ntlvpNhg1zhou0jDVYFniEXvzjckxswHVb8cT0OMTKHALyLPrPOJzVtM9C1ew2Nnc\n3848xLiApMu3NBk0JqfcS3Bo5Y2b1FRVBvdt+2gFoKZix1MnZdAEZ8xQzL/a0YS5\nHd0wj5+EEKHfOd3A75uPa/WQmA+o0cBFfrzm69QDcSJSwGpzWrD1ScH3AK8nWvoj\nv7e9gukK/9yl1b4fQQ00vttwJPSgm9EnfPHLAtgXkRloI27H6/PuLoNvSAMQwuCD\nhQRlyGLPBETKkHeodfLoULjhDi1K2gKJTMhtbnUcAA7nEphkMhPWkBpgFdrH+5z4\nLxy+3ek0cqcI7K68EtrffU8jtUj9LFTUC8dERaIBs7NgQ/LfDbDfGh9g6qVj1hZl\nk9aaIPTm/xsi8v3u+0qaq7KzIBc9s59JOoA8TlpOaYdVgSQhHHLBaahOuAigH+VI\nisbC9vmqsThF2QdDtQt37keuqoda2E6sL7PUvIyVXDRfwX7uMDjlzTxHTymvq2Ck\nhtBqojBnThmjJQFgZXocHG8CAwEAAQ==
+ '
+ # List of directories to remove when empty.
+ readonly UNNECESSARY_DIRS='
diff --git a/community/alpine-make-rootfs/fix-missing-release-files-on-edge.patch b/community/alpine-make-rootfs/fix-missing-release-files-on-edge.patch
new file mode 100644
index 00000000000..7eeeddb797b
--- /dev/null
+++ b/community/alpine-make-rootfs/fix-missing-release-files-on-edge.patch
@@ -0,0 +1,39 @@
+Patch-Source: https://github.com/alpinelinux/alpine-make-rootfs/commit/80a8e3f9d6f5ec701b2ae5e9a0d6bdb004ec1246
+--
+From 80a8e3f9d6f5ec701b2ae5e9a0d6bdb004ec1246 Mon Sep 17 00:00:00 2001
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sun, 21 Aug 2022 00:56:04 +0200
+Subject: [PATCH] Adapt to alpine-base not providing release files since v3.17
+ and on edge
+
+https://gitlab.alpinelinux.org/alpine/aports/-/commit/23e66e85c95beef9d3f72a2ccc510671fdb3462d
+---
+ alpine-make-rootfs | 15 ++++++++++-----
+ 1 file changed, 10 insertions(+), 5 deletions(-)
+
+diff --git a/alpine-make-rootfs b/alpine-make-rootfs
+index 63133f3..eb24005 100755
+--- a/alpine-make-rootfs
++++ b/alpine-make-rootfs
+@@ -387,11 +387,16 @@ fi
+
+ _apk add --root "$rootfs" --update-cache --initdb $rootfs_pkgs >&2
+
+-if ! _apk info --root "$rootfs" --quiet --installed alpine-base; then
+- # This package contains /etc/os-release, /etc/alpine-release and /etc/issue,
+- # but we don't wanna install all its dependencies (e.g. openrc).
+- _apk fetch --root "$rootfs" --stdout alpine-base \
+- | tar -xz -C "$rootfs" etc >&2
++if ! [ -f "$rootfs"/etc/alpine-release ]; then
++ if _apk info --root "$rootfs" --quiet alpine-release >/dev/null; then
++ _apk add --root "$rootfs" alpine-release
++ else
++ # In Alpine <3.17, this package contains /etc/os-release,
++ # /etc/alpine-release and /etc/issue, but we don't wanna install all
++ # its dependencies (e.g. openrc).
++ _apk fetch --root "$rootfs" --stdout alpine-base \
++ | tar -xz -C "$rootfs" etc >&2
++ fi
+ fi
+
+ [ -e "$rootfs"/var/run ] || ln -s /run "$rootfs"/var/run