aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2022-05-17 05:30:05 +0000
committeralice <alice@ayaya.dev>2022-05-18 23:50:07 +0000
commit1fc38958f8bfc5bbb60164132909c4bf2d97b80a (patch)
tree4e028741db6b3821c1b8279bcab5b3527b18399c
parent019517709e235b256cd08f6cadcb02f126b62939 (diff)
community/ceph: upgrade to 16.2.8
https://ceph.io/en/news/blog/2022/v16-2-8-pacific-released/
-rw-r--r--community/ceph/12-package.json-resolutions.patch13
-rw-r--r--community/ceph/30-cypress.patch.noauto8
-rw-r--r--community/ceph/32-PurgeQueue.cc-cast.patch85
-rw-r--r--community/ceph/42-no-virtualenvs.patch2
-rw-r--r--community/ceph/APKBUILD14
5 files changed, 12 insertions, 110 deletions
diff --git a/community/ceph/12-package.json-resolutions.patch b/community/ceph/12-package.json-resolutions.patch
index ddc4ea2106a..a25479e0739 100644
--- a/community/ceph/12-package.json-resolutions.patch
+++ b/community/ceph/12-package.json-resolutions.patch
@@ -4,7 +4,7 @@
add_npm_command(
OUTPUT "${CMAKE_SOURCE_DIR}/src/pybind/mgr/dashboard/frontend/node_modules"
-- COMMAND CYPRESS_CACHE_FOLDER=${CMAKE_SOURCE_DIR}/build/src/pybind/mgr/dashboard/cypress NG_CLI_ANALYTICS=false npm ci ${mgr-dashboard-userconfig}
+- COMMAND CYPRESS_CACHE_FOLDER=${CMAKE_SOURCE_DIR}/build/src/pybind/mgr/dashboard/cypress NG_CLI_ANALYTICS=false npm ci -f ${mgr-dashboard-userconfig}
+ COMMAND CYPRESS_CACHE_FOLDER=${CMAKE_SOURCE_DIR}/build/src/pybind/mgr/dashboard/cypress NG_CLI_ANALYTICS=false yarn install --network-timeout 600000 --frozen-lockfile ${mgr-dashboard-userconfig}
DEPENDS frontend/package.json
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/pybind/mgr/dashboard/frontend
@@ -18,14 +18,3 @@
DEPENDS ${frontend_src} frontend/node_modules
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/pybind/mgr/dashboard/frontend
COMMENT "dashboard frontend is being created"
---- a/src/pybind/mgr/dashboard/frontend/package.json
-+++ b/src/pybind/mgr/dashboard/frontend/package.json
-@@ -142,8 +142,5 @@
- "ts-node": "9.0.0",
- "tslint": "6.1.3",
- "typescript": "4.1.6"
-- },
-- "resolutions": {
-- "fsevents": "2.1.3"
- }
- }
diff --git a/community/ceph/30-cypress.patch.noauto b/community/ceph/30-cypress.patch.noauto
index fecf0559155..2b4b4abd21e 100644
--- a/community/ceph/30-cypress.patch.noauto
+++ b/community/ceph/30-cypress.patch.noauto
@@ -4,11 +4,11 @@ diff -Nurp a/src/pybind/mgr/dashboard/frontend/package.json b/src/pybind/mgr/das
--- a/src/pybind/mgr/dashboard/frontend/package.json 2021-04-03 08:58:07.611941559 +0100
+++ b/src/pybind/mgr/dashboard/frontend/package.json 2021-04-03 08:59:13.903122038 +0100
@@ -119,8 +119,6 @@
- "@types/node": "12.12.62",
"@types/simplebar": "5.1.1",
- "codelyzer": "6.0.1",
-- "cypress": "5.3.0",
-- "cypress-multi-reporters": "1.4.0",
+ "@types/swagger-ui": "3.52.0",
+ "codelyzer": "6.0.2",
+- "cypress": "9.0.0",
+- "cypress-multi-reporters": "1.5.0",
"html-linter": "1.1.1",
"htmllint-cli": "0.0.7",
"identity-obj-proxy": "3.0.0",
diff --git a/community/ceph/32-PurgeQueue.cc-cast.patch b/community/ceph/32-PurgeQueue.cc-cast.patch
deleted file mode 100644
index 19a0719c4ad..00000000000
--- a/community/ceph/32-PurgeQueue.cc-cast.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-Submitted as: https://github.com/ceph/ceph/pull/41235
-
-commit 953e7dc0f911f84a4bb377aee45b22e2ffad6867
-Author: Duncan Bellamy <dunk@denkimushi.com>
-Date: Sat May 8 11:52:35 2021 +0100
-
- mds: PurgeQueue.cc add static cast for 32bit compilation
-
- files_high_water is defined as uint64_t but when compiling on 32bit these max functions
- fail as they are both not considered uint64_t by gcc 10 even though they are
-
- files_high_water = std::max(files_high_water,
- static_cast<uint64_t>(in_flight.size()));
-
- Fixes: https://tracker.ceph.com/issues/50707
-
- Signed-off-by: Duncan Bellamy <dunk@denkimushi.com>
-
-diff --git a/src/mds/PurgeQueue.cc b/src/mds/PurgeQueue.cc
-index 977be2c118..3104a3ccc4 100644
---- a/src/mds/PurgeQueue.cc
-+++ b/src/mds/PurgeQueue.cc
-@@ -7,9 +7,9 @@
- *
- * This is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public
-- * License version 2.1, as published by the Free Software
-+ * License version 2.1, as published by the Free Software
- * Foundation. See file COPYING.
-- *
-+ *
- */
-
- #include "common/debug.h"
-@@ -594,8 +594,8 @@ void PurgeQueue::_execute_item(
-
- in_flight[expire_to] = item;
- logger->set(l_pq_executing, in_flight.size());
-- files_high_water = std::max(files_high_water,
-- static_cast<uint64_t>(in_flight.size()));
-+ files_high_water = std::max<uint64_t>(files_high_water,
-+ in_flight.size());
- logger->set(l_pq_executing_high_water, files_high_water);
- auto ops = _calculate_ops(item);
- ops_in_flight += ops;
-@@ -662,8 +662,8 @@ void PurgeQueue::_execute_item(
- logger->set(l_pq_executing_ops_high_water, ops_high_water);
- in_flight.erase(expire_to);
- logger->set(l_pq_executing, in_flight.size());
-- files_high_water = std::max(files_high_water,
-- static_cast<uint64_t>(in_flight.size()));
-+ files_high_water = std::max<uint64_t>(files_high_water,
-+ in_flight.size());
- logger->set(l_pq_executing_high_water, files_high_water);
- return;
- }
-@@ -716,19 +716,19 @@ void PurgeQueue::_execute_item_complete(
-
- in_flight.erase(iter);
- logger->set(l_pq_executing, in_flight.size());
-- files_high_water = std::max(files_high_water,
-- static_cast<uint64_t>(in_flight.size()));
-+ files_high_water = std::max<uint64_t>(files_high_water,
-+ in_flight.size());
- logger->set(l_pq_executing_high_water, files_high_water);
- dout(10) << "in_flight.size() now " << in_flight.size() << dendl;
-
-- uint64_t write_pos = journaler.get_write_pos();
-- uint64_t read_pos = journaler.get_read_pos();
-- uint64_t expire_pos = journaler.get_expire_pos();
-- uint64_t item_num = (write_pos - (in_flight.size() ? expire_pos : read_pos))
-+ uint64_t write_pos = journaler.get_write_pos();
-+ uint64_t read_pos = journaler.get_read_pos();
-+ uint64_t expire_pos = journaler.get_expire_pos();
-+ uint64_t item_num = (write_pos - (in_flight.size() ? expire_pos : read_pos))
- / purge_item_journal_size;
-- dout(10) << "left purge items in journal: " << item_num
-- << " (purge_item_journal_size/write_pos/read_pos/expire_pos) now at "
-- << "(" << purge_item_journal_size << "/" << write_pos << "/" << read_pos
-+ dout(10) << "left purge items in journal: " << item_num
-+ << " (purge_item_journal_size/write_pos/read_pos/expire_pos) now at "
-+ << "(" << purge_item_journal_size << "/" << write_pos << "/" << read_pos
- << "/" << expire_pos << ")" << dendl;
-
- logger->set(l_pq_item_in_journal, item_num);
diff --git a/community/ceph/42-no-virtualenvs.patch b/community/ceph/42-no-virtualenvs.patch
index 541b3387985..c5ec37b8fd2 100644
--- a/community/ceph/42-no-virtualenvs.patch
+++ b/community/ceph/42-no-virtualenvs.patch
@@ -4,9 +4,9 @@ use system node instead of nodeenv installing one as only availiable for x86 wit
--- a/cmake/modules/AddCephTest.cmake
+++ b/cmake/modules/AddCephTest.cmake
@@ -68,14 +68,6 @@
+ list(APPEND tox_envs py3)
endif()
string(REPLACE ";" "," tox_envs "${tox_envs}")
- find_package(Python3 QUIET REQUIRED)
- add_custom_command(
- OUTPUT ${venv_path}/bin/activate
- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python="${Python3_EXECUTABLE}" ${venv_path}
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index eb562e1e56c..60206a73b03 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=ceph
-pkgver=16.2.7
-pkgrel=6
+pkgver=16.2.8
+pkgrel=0
pkgdesc="Ceph is a distributed object store and file system"
pkgusers="ceph"
pkggroups="ceph"
@@ -119,7 +119,6 @@ source="https://download.ceph.com/tarballs/ceph_$pkgver.orig.tar.gz
30-cypress.patch.noauto
30-ubuntu-32bit-fixes.patch.noauto
31-32bit_fix_tests.patch.noauto
- 32-PurgeQueue.cc-cast.patch
32-upstream32bit.patch
32-upstream32bitcleanup.patch
35-fix_ErasureCodeShec.patch
@@ -547,25 +546,24 @@ mgr() {
}
sha512sums="
-eab047e646970d444acf1064d98237b8b1677fb16b5e771082d55880f7bc6d8bdb278c2fe514c82ae12c438878d9ecea29139fa6b8d890f9f737138f10fb740c ceph_16.2.7.orig.tar.gz
+5ea3857d6ba401d3ac969d95eaed4ea9f43bba1dc25b1c84a9ca14420d790413b8eda953edd576341c79d937433adce0c268f2e8bde9137bbd69f4535b0cc740 ceph_16.2.8.orig.tar.gz
110bdbcb40216c7ed155a8d23020784741b4992d895f4f04a146d275506e4e68053854d3b063b41e9c9b3e3e4f95b6b90602f92c185c853c0d8f47ad0c6b7121 ceph.confd
ce5f162501f6b67fe254546dddf880d1a5b1d1a0fa69e0b1918de17e8da45c5c6124512b8cbd98b76f29d931403de0d11c5ffd330ed8ee1f4dc75bb04baecae3 ceph.initd
94687578411bf0de1b17555ed81c188c88ea63ac4a25993bd8fde9cf68afbbfbdec7b2d7c54fdcfbd4aed4eb78754e8061c308955596cbe037ff15b575874cc6 10-musl-fixes.patch
211e6f5f8fc962878196ec917984781eb4a8a9495bcc8d1729b34ac66abd2d4a0b7388ae2caee9d5deb664d54860d120a37215924625e82eac9bfca16179667a 11-dump_time_header_impl.patch
17afbb87e11014acbd67c24afbc178cfa4e14776c1160cecaa03b4e933bab961d13ce9fb1924097dd8f544e3cd5ad84a844c7d3b54aa939ea63a13924369e1e0 11-parse_rfc1123_alt.patch
52b11dfd157dfb7363d2d3428901559189263caaa1c5f29a924b9be7ea012d4f54a887b22d2e2a3d756f6fd771f626505912dca52e6b19a56e018be45b7acb8b 11-s3_expiration_header.patch
-811016db05490d611258f336a0e6064173dfcda1a2bb2a5c8817bbb5fe26d101bd58de02fa17041d9e4ed4da6e383e376e9a7f1b1d133c5922b2f6f684175791 12-package.json-resolutions.patch
+9d985d19fc70f24179532831b4b19a3bfc074743542cf8d9badd60c21b02bfefbafd12b7c8530d79d9f185c7213580de19cc1e28ab4c2338b0faa52cf4acdd25 12-package.json-resolutions.patch
03ef3598181c45ecba5600a1e4db7fd897ea9d3c8abdfaad2dcf84c7a241d9ba18e7f7885d69ee0572ee307fc94600a2784a07da909d37a51de27f8ded2e3a70 20-pci.patch
b879993a285a771c3640c5214ff70e8e01673c0c5e23a0f88ac70db168aeb1dd2eaed12805ed5076adae5a0f596abcb9d82220c6fd97643169cb92788898a189 30-32bit_fix.patch.noauto
-2eebc4501d40edf92c5302b25dea554807caba6abd22a3569d708db8a057085d74a3ecdac2adab54edb0619cf3d74884e1d44ef95d991a069dd473279819b974 30-cypress.patch.noauto
+5574eda9f1a2f4a98defb380f78fc3a9a9e393d3043468f6af74967181fa912066a4d408ba27721f1f1f7625f4162a8e172fa259dcf36d1b9123be1875af057e 30-cypress.patch.noauto
01c446ac4528d8e12d3544f603ba32a0bf0d5a3a72f9f8f3726725f9d225ee447d2fea4ee2ddf10b36498cc01f2ecf51175dbfcc6376aac4c8002f52c6a04299 30-ubuntu-32bit-fixes.patch.noauto
f974ab36cd6fa49c1d4613203a4f2152723e4952a185dfb6349bc4ca8ee1a7a9d0477bea136c54248271de30a4e584734ba41e8ec41bf274b04074622888ae39 31-32bit_fix_tests.patch.noauto
-964e7ca107cc731be2be7bf6813aca760ca1c6e6f6b3748103c1e6baef4d25e41442752a72f5e5daed2b1c6c4f96c9aebbb7114247e8a5047511fbd035767aeb 32-PurgeQueue.cc-cast.patch
fb69f1c886f3cc05a10dd8722429c6bdc840674113e83cf3592caf75b5d4082e5bdaea73426b28edbde724c4973775f2109a3eb4e0a84384fa8083621d463fbd 32-upstream32bit.patch
73326b47deb0967ff024731c28a956ca63800ffcbfa36c6351c157328d2036b3f8406368cc7c7e087841e144b32889f27d807f3405ac1c5a1c2daf6bd7ca5338 32-upstream32bitcleanup.patch
abb3cab9c01cc3d6d42a9858678059a8c9c43bda2649bf97b489fdc205eb10ae27f9fb7302062e0fb41f5cffddbfc2ae529130569034f373732a0a5d33aba86e 35-fix_ErasureCodeShec.patch
908169df45177240d2dcc721fe1637c521789aed56c3b3400ed3ba9c73d93634e4369258fb0e0395dc27053be26229ee8f370e445f0e69d01f551a710a29d407 37-fix_tests.patch
-191c31788fa70335d16477004ba406f608045d58cbdd00818c86d3253672f48f3114c432dfde80db1992f1e4e79f6898182e7ba9d5a855227ff5ce6a16b7b5de 42-no-virtualenvs.patch
+f9a0a041dbf10d5131964e0e479b47a7205bd6973335a478357861dd6651dfb79451c8cf027f71522b059765a07b842c3a71f23950134fdb4184e3f3821cfcd0 42-no-virtualenvs.patch
6f4235d0ab591d4fb3ea9327199a5149821f20d05aebe21c01430d1ac793bb3083f13884db1ac670dd51c074e6d769672fab27001392213f7b997bb0b5187493 43-LogClock.h.patch
545bcfd907937029e316487bd5cfe96aba2ca4dd1aa09d0c7901662a35c4bd63a71aa83773fdd05ab1889e5f73c47382fedcafbd90c371b01213f028d7136973 44-aarch64-erasure.patch
624ff72debfb698d681b187c99da9e927c6e4f5df7bc741b7dd196a9ee20773ac8a0f103314983faa29b934e6753407a02abfec2553feb1c3e1fcf20772cb1d9 44-cmake-buildtype.patch