aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-12-29 12:53:14 +0100
committerBart Ribbers <bribbers@disroot.org>2021-12-29 12:01:40 +0000
commit20297e6da51a7c08ecbd5a2f85f345427cdbc6d4 (patch)
tree799745f6f0d187bfe935b9425d3049ab7a64b403
parenta1da03a70688aac5597010ce8769268b665dcf4b (diff)
downloadaports-20297e6da51a7c08ecbd5a2f85f345427cdbc6d4.tar.gz
aports-20297e6da51a7c08ecbd5a2f85f345427cdbc6d4.tar.bz2
aports-20297e6da51a7c08ecbd5a2f85f345427cdbc6d4.tar.xz
community/polkit: fix upgrading from polkit-elogind < 0.118
(84/885) Installing polkit-elogind-libs (0.119-r6) ERROR: polkit-elogind-libs-0.119-r6: trying to overwrite usr/lib/libpolkit-agent-1.so.0 owned by polkit-elogind-0.118-r1. ERROR: polkit-elogind-libs-0.119-r6: trying to overwrite usr/lib/libpolkit-agent-1.so.0.0.0 owned by polkit-elogind-0.118-r1. ERROR: polkit-elogind-libs-0.119-r6: trying to overwrite usr/lib/libpolkit-gobject-1.so.0 owned by polkit-elogind-0.118-r1. ERROR: polkit-elogind-libs-0.119-r6: trying to overwrite usr/lib/libpolkit-gobject-1.so.0.0.0 owned by polkit-elogind-0.118-r1.
-rw-r--r--community/polkit/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/polkit/APKBUILD b/community/polkit/APKBUILD
index 835f2fa40a..c2480bf808 100644
--- a/community/polkit/APKBUILD
+++ b/community/polkit/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=polkit
pkgver=0.120
-pkgrel=0
+pkgrel=1
pkgdesc="Application development toolkit for controlling system-wide privileges"
url="https://www.freedesktop.org/wiki/Software/polkit/"
arch="all !mips !mips64 !s390x !riscv64" # Rust
@@ -180,7 +180,7 @@ _elogind_libs() {
depends=""
provides="$pkgname-libs=$pkgver-r$pkgrel"
provider_priority=10 # lowest
- replaces="$pkgname-libs" # for backward compatibility
+ replaces="$pkgname-libs $pkgname-elogind<=0.118" # for backward compatibility
cd "$builddir-elogind/dest"