aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-17 17:56:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-17 18:00:03 +0100
commit2056d07f98630a740454b69920a6a4cd5238a1e0 (patch)
tree1edd7f9d0b6b91f26ab3d368df7e6a5289aba04c
parent25cc3d7d1fa02ef2bc4124e92ed8d3aa95dce9a8 (diff)
downloadaports-2056d07f98630a740454b69920a6a4cd5238a1e0.tar.gz
aports-2056d07f98630a740454b69920a6a4cd5238a1e0.tar.bz2
aports-2056d07f98630a740454b69920a6a4cd5238a1e0.tar.xz
community/lua-lpeg_patterns: don't rely on install_if in checkdepends
To not complicate dependency graph and also workaround some not yet described bug in apk.
-rw-r--r--community/lua-lpeg_patterns/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/lua-lpeg_patterns/APKBUILD b/community/lua-lpeg_patterns/APKBUILD
index 6fa405fa22..066c749115 100644
--- a/community/lua-lpeg_patterns/APKBUILD
+++ b/community/lua-lpeg_patterns/APKBUILD
@@ -9,7 +9,7 @@ url="https://github.com/daurnimator/lpeg_patterns"
arch="noarch"
license="MIT"
depends="lua-lpeg"
-checkdepends="lua-busted"
+checkdepends=""
subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -23,7 +23,7 @@ esac
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
- checkdepends="$checkdepends lua$_v"
+ checkdepends="$checkdepends lua$_v lua$_v-busted"
done
check() {