aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-09 18:24:49 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-09 18:27:24 +0100
commit20e66fe784fc00e23733ae9d59092fdeec1d6253 (patch)
tree1db3468402b3d16c38bae86b05325645134def30
parent8530b1bd92515675782ad22333ef86cc1c97754c (diff)
community/ocaml-camlp4: add -dev subpkg
-rw-r--r--community/lablgtk/APKBUILD2
-rw-r--r--community/ocaml-camlp4/APKBUILD21
-rw-r--r--community/opam/APKBUILD2
-rw-r--r--testing/haxe/APKBUILD2
4 files changed, 24 insertions, 3 deletions
diff --git a/community/lablgtk/APKBUILD b/community/lablgtk/APKBUILD
index d7f99de6fc3..c824ab4d615 100644
--- a/community/lablgtk/APKBUILD
+++ b/community/lablgtk/APKBUILD
@@ -10,7 +10,7 @@ arch="x86_64 ppc64le"
license="GPL"
depends_dev="lablgtk gtk+-dev gtkspell-dev librsvg-dev gtksourceview2-dev"
depends="ocaml-findlib ocaml-camlp4 ocaml"
-makedepends="$depends $depends_dev"
+makedepends="$depends $depends_dev ocaml-camlp4-dev"
subpackages="$pkgname-doc $pkgname-dev"
source="https://forge.ocamlcore.org/frs/download.php/1627/lablgtk-$pkgver.tar.gz"
builddir="$srcdir/lablgtk-$pkgver"
diff --git a/community/ocaml-camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
index ea97256ea9d..5f59d60ee89 100644
--- a/community/ocaml-camlp4/APKBUILD
+++ b/community/ocaml-camlp4/APKBUILD
@@ -1,4 +1,5 @@
# Contributor: Jon Ong <jonongjs@rottenmage.com>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
pkgname=ocaml-camlp4
_pkgname=camlp4
@@ -12,9 +13,11 @@ url="https://github.com/ocaml/camlp4/releases"
arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
license="LGPL-2.0-or-later-WITH-linking-exception"
depends="ocaml"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
makedepends="ocamlbuild"
replaces="camlp4" # for backward compatibility
provides="camlp4=$pkgver-r$pkgrel" # for backward compatibility
+subpackages="$pkgname-dev"
source="$_pkgname-$_pkgver.tar.gz::https://github.com/ocaml/$_pkgname/archive/$_pkgver.tar.gz"
builddir="$srcdir/$_pkgname-${_pkgver/+/-}"
@@ -34,4 +37,22 @@ package() {
install install-META
}
+dev() {
+ default_dev
+ replaces="camlp4" # for backward compatibility
+ local sitelib="usr/lib/ocaml/$_pkgname"
+
+ cd "$pkgdir"
+
+ mkdir -p "$subpkgdir"/usr
+ mv usr/bin "$subpkgdir"/usr/
+
+ local path
+ for path in $(find $sitelib/ -name '*.cmx' -o -name '*.cmxa'); do
+ mkdir -p "$subpkgdir"/${path%/*}
+ mv "$path" "$subpkgdir"/${path%/*}/
+ done
+ rmdir "$subpkgdir"/$sitelib 2>/dev/null || true
+}
+
sha512sums="7db8eebcf3d230f60650ba62d9cb630c069394237e97b678a40b61d3dcaded752a2b7e089a50ff528f1ea0740d0291b722df123a072f2cee489cadc5201c6776 camlp4-4.04+1.tar.gz"
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index a234527260b..b16097d7c0d 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -8,7 +8,7 @@ url="https://opam.ocaml.org"
arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
license="LGPL-3.0"
depends="ocaml ocaml-camlp4 curl tar unzip rsync aspcud patch"
-makedepends="$depends_dev"
+makedepends="ocaml-camlp4-dev"
source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz
fix-default-stubsdir.patch"
builddir="$srcdir/$pkgname-full-$pkgver"
diff --git a/testing/haxe/APKBUILD b/testing/haxe/APKBUILD
index dfe41d374eb..e5d6a4e8a37 100644
--- a/testing/haxe/APKBUILD
+++ b/testing/haxe/APKBUILD
@@ -9,7 +9,7 @@ url="https://haxe.org"
arch="x86_64 aarch64 ppc64le"
license="GPL MIT LGPL" # http://haxe.org/foundation/open-source.html
depends=""
-makedepends="ocaml-camlp4 ocaml neko-dev zlib-dev pcre-dev"
+makedepends="ocaml-camlp4-dev ocaml neko-dev zlib-dev pcre-dev"
options="!strip !makeflags"
install=""
subpackages="$pkgname-doc"