aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-17 14:54:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-17 14:54:58 +0000
commit212df81b24ed85e6c24faccf338b08bb73739f4b (patch)
treec95d954cc4e38782717d0a0a2860e820d0eeae5e
parentcf6a7e46a0979b362cc5a3b66154a0a533f55ad7 (diff)
main/py-six: disable test to fix circular deps with pytest
-rw-r--r--main/py-six/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/main/py-six/APKBUILD b/main/py-six/APKBUILD
index 18c3b0f0e49..856271679a2 100644
--- a/main/py-six/APKBUILD
+++ b/main/py-six/APKBUILD
@@ -7,17 +7,15 @@ pkgdesc="Python 2 and 3 compatibility library"
url="https://pypi.python.org/pypi/six"
arch="noarch"
license="MIT"
-checkdepends="pytest py3-pytest"
_py2_deps="py-enum34"
makedepends="python2-dev python3-dev py2-setuptools py3-setuptools $_py2_deps"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="$pkgname-$pkgver.tar.gz::https://github.com/benjaminp/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-if [ -n "$BOOTSTRAP" ]
-then
- # circular dependency with pytest
- options="!check"
-fi
+
+# circular dependency with pytest
+#checkdepends="pytest py3-pytest"
+options="!check"
build() {
python2 setup.py build