aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2023-02-15 23:00:37 +0100
committeralice <alice@ayaya.dev>2023-02-17 04:13:46 +0000
commit2141414abd294b162f642112672bb4ee378c2b26 (patch)
tree857fc62608c3912b4c383dff7d795c6f0c27bf0b
parent66c2872e8c295d4042604d3baa5ac14d577f1bfc (diff)
testing/wayqt: new aport
-rw-r--r--testing/wayqt/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/wayqt/APKBUILD b/testing/wayqt/APKBUILD
new file mode 100644
index 00000000000..8ce62a76080
--- /dev/null
+++ b/testing/wayqt/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
+pkgname=wayqt
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="Qt-based wrapper for various wayland protocols"
+url="https://gitlab.com/desktop-frameworks/wayqt"
+arch="all"
+license="MIT"
+makedepends="
+ meson
+ qt5-qtbase-dev
+ wayland-protocols
+ wlroots-dev
+"
+subpackages="$pkgname-dev"
+source="https://gitlab.com/desktop-frameworks/wayqt/-/archive/v$pkgver/wayqt-v$pkgver.tar.gz"
+builddir="$srcdir/wayqt-v$pkgver"
+options="!check" # no test suite
+
+build() {
+ abuild-meson \
+ -Duse_qt_version=qt5 \
+ output
+ meson compile -C output
+}
+
+check() {
+ :
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+ed84c07be4a8e95d08554e23f537b089b186e1b67931059461ae8584fbfab38d921f85aee5b8a00e0806eee7ae9e6331a99963d2c06efb1124becabf1471edd2 wayqt-v0.1.1.tar.gz
+"