aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-20 17:11:40 -0300
committerJakub Jirutka <jakub@jirutka.cz>2020-12-21 14:02:12 +0000
commit22e0bd0d4a1e25373e06a090c6ae23918bebd0b4 (patch)
tree973d1b0188b130b281ac07c585f61ce01f28160b
parente4215ca427e54b08889bd7249a0df87d8edcaef2 (diff)
downloadaports-22e0bd0d4a1e25373e06a090c6ae23918bebd0b4.tar.gz
aports-22e0bd0d4a1e25373e06a090c6ae23918bebd0b4.tar.bz2
aports-22e0bd0d4a1e25373e06a090c6ae23918bebd0b4.tar.xz
community/suitesparse: force installation of headers into usr/include
Seems like the builders act differently than CI and try to install headers into /usr/local/include. [1] Relevant log snippet: ``` make[3]: Leaving directory '/home/buildozer/aports/community/suitesparse/src/SuiteSparse-5.6.0/GraphBLAS/build' Install the project... -- Install configuration: "Release" -- Installing: /home/buildozer/aports/community/suitesparse/pkg/suitesparse/usr/lib/libgraphblas.so.3.1.1 -- Installing: /home/buildozer/aports/community/suitesparse/pkg/suitesparse/usr/lib/libgraphblas.so.3 -- Installing: /home/buildozer/aports/community/suitesparse/pkg/suitesparse/usr/lib/libgraphblas.so CMake Error at cmake_install.cmake:107 (file): file cannot create directory: /usr/local/include. Maybe need administrative privileges. ``` Note that this did not happen on CI in !15718 [2][3] [1] https://build.alpinelinux.org/buildlogs/build-edge-x86_64/community/suitesparse/suitesparse-5.6.0-r2.log [2] https://gitlab.alpinelinux.org/Leo/aports/-/pipelines/63917 [3] https://gitlab.alpinelinux.org/Leo/aports/-/pipelines/63916
-rw-r--r--community/suitesparse/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/suitesparse/APKBUILD b/community/suitesparse/APKBUILD
index c4de6c7cd32..e28d43a6671 100644
--- a/community/suitesparse/APKBUILD
+++ b/community/suitesparse/APKBUILD
@@ -29,7 +29,8 @@ prepare() {
build() {
#BLAS=-lblas
make library \
- CMAKE_OPTIONS="-DCMAKE_INSTALL_LIBDIR=$pkgdir/usr/lib"
+ CMAKE_OPTIONS="-DCMAKE_INSTALL_LIBDIR=$pkgdir/usr/lib \
+ -DCMAKE_INSTALL_INCLUDEDIR=$pkgdir/usr/include"
}
package() {