aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-02-02 09:11:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-02-02 09:24:59 +0000
commit235ddf2b8ff0aeb8fb3b3fb2c0bf061d05e7924d (patch)
tree454d1283c0ba49ad3ffd1fdf512399e9269dc8f8
parentac7fb85c9e101a3030eb5e1e42cef5896fc19cf8 (diff)
community/openjdk8: fix permissions of *.jar
gnu find seems to not support the '-perm +006' anymore. use '-perm /006'
-rw-r--r--community/openjdk8/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index 3019901a2aa..70723472c1d 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -5,7 +5,7 @@ _java_ver=8
_jdk_update=72
_jdk_build=15
pkgver=$_java_ver.$_jdk_update.$_jdk_build
-pkgrel=0
+pkgrel=1
pkgdesc="Sun OpenJDK 8"
url="http://openjdk.java.net"
arch="x86_64 x86"
@@ -139,10 +139,10 @@ package() {
cp -a "$_builddir"/build/*/images/j2sdk-image/* "$pkgdir"/$INSTALL_BASE
rm "$pkgdir"/$INSTALL_BASE/src.zip
- find "$pkgdir"/$INSTALL_BASE -iname "*.diz" -delete
- find "$pkgdir"/$INSTALL_BASE -iname "*.debuginfo" -delete
- find "$pkgdir"/$INSTALL_BASE \( -name "*.jar" -o -name "*.sym" \) \! -perm +006 \
- | xargs chmod go+r
+ find "$pkgdir"/$INSTALL_BASE -iname "*.diz" -delete || return 1
+ find "$pkgdir"/$INSTALL_BASE -iname "*.debuginfo" -delete || return 1
+ find "$pkgdir"/$INSTALL_BASE \( -name "*.jar" -o -name "*.sym" \) \
+ \! -perm /006 | xargs chmod go+r || return 1
pax_mark_vm "$pkgdir"/$INSTALL_BASE