aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-07-22 16:39:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-07-22 16:39:53 -0300
commit236366d8a0ad1d471ee032ebfe1036bddd78e247 (patch)
tree9cf5123ce41af91fe9c211f205f1c69bbcf8e931
parenta95c802cd02f474a951599a36103166d2da890f6 (diff)
main/libdnet: upgrade to 1.14
-rw-r--r--main/libdnet/APKBUILD22
-rw-r--r--main/libdnet/automake.patch11
2 files changed, 9 insertions, 24 deletions
diff --git a/main/libdnet/APKBUILD b/main/libdnet/APKBUILD
index f7b9bc620ed..e62967c01ad 100644
--- a/main/libdnet/APKBUILD
+++ b/main/libdnet/APKBUILD
@@ -1,24 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libdnet
-pkgver=1.12
-pkgrel=8
-pkgdesc="A simplified, portable interface to several low-level networking routines"
+pkgver=1.14
+pkgrel=0
+pkgdesc="simplified, portable interface to several low-level networking routines"
url="https://github.com/dugsong/libdnet"
arch="all"
license="BSD-3-Clause"
+makedepends="linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
-makedepends="autoconf automake bash libtool linux-headers"
-source="https://github.com/dugsong/libdnet/archive/libdnet-$pkgver.tar.gz
- automake.patch
- "
+source="https://github.com/dugsong/libdnet/archive/libdnet-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgname-$pkgver
prepare() {
default_prepare
- # the libtool script does not add .so extention to we generate
- # new libtool
- aclocal -I config && autoconf && automake --force --add-missing \
- && libtoolize
+ update_config_sub
}
build() {
@@ -35,5 +30,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a2410a98b76d4bccecf7bcb82ff0b6e9fb809b389f7fea938cc42d94e18622cc5f353d2de737121a1990d9e16e9db8cc2f82677c94f78cd03c9227e815eab9e0 libdnet-1.12.tar.gz
-8a47795c5edb5f67df46a59f2f4d8798b2e34f34e0aae3202a6cca8e475f105e08fa5586a432fba9f443c1df57441cffcdc08f5e4eb53df8e73c2a6c8c075477 automake.patch"
+sha512sums="
+ce8d95228f5175e4d9a8ff71bb99eb1ccc3ccd599a85dd07adbfd9842fc54066235d362c8060828fb3ba8129d0e1e8e071e93d60d69c6d03be310c80e61cea93 libdnet-1.14.tar.gz
+"
diff --git a/main/libdnet/automake.patch b/main/libdnet/automake.patch
deleted file mode 100644
index c6c257f3efb..00000000000
--- a/main/libdnet/automake.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./configure.in.orig 2012-12-31 19:55:17.838213967 +0000
-+++ ./configure.in 2012-12-31 19:55:31.191667853 +0000
-@@ -10,7 +10,7 @@
- AC_SUBST(ac_aux_dir)
-
- AM_INIT_AUTOMAKE(libdnet, 1.12)
--AM_CONFIG_HEADER(include/config.h)
-+AC_CONFIG_HEADER(include/config.h)
-
- dnl XXX - stop the insanity!@#$
- AM_MAINTAINER_MODE