aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-12-19 11:55:39 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-12-19 12:55:36 +0000
commit24879f3f4836a148e5cc0ba868c36513cdccdf91 (patch)
treefa6e194d35ceafd3246b4a0c6e1f97ea04e20e9a
parent82fdc4a1c2179a4d46ddfabdca44a980e5cac502 (diff)
community/monkey: build with -fcommon
GCC10 builds with `-fno-common` by default. This results into 'multiple definition' errors in projects that define the same variable multiple times. The proper fix is to adjust the source, but in this cases there are many instances, so build with `-fcommon` for now.
-rw-r--r--community/monkey/APKBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/community/monkey/APKBUILD b/community/monkey/APKBUILD
index 0c71cb19292..a307372e967 100644
--- a/community/monkey/APKBUILD
+++ b/community/monkey/APKBUILD
@@ -18,6 +18,9 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
+
+ export CFLAGS="$CFLAGS -fcommon"
+
./configure \
--musl-mode \
--no-backtrace \