aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-02 00:46:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-15 02:12:57 +0000
commit24f1e371fe64418734791b340aed4aad078fcc12 (patch)
treed1d4cf4b80d96733b76f3bc7a39d5ee918b43c57
parent175ff6dd5565feede2bfa918c82b06a5efb532d0 (diff)
community/py3-pygit2: upgrade to 1.2.1
-rw-r--r--community/py3-pygit2/APKBUILD9
-rw-r--r--community/py3-pygit2/skip-failing-test-on-s390x.patch13
2 files changed, 3 insertions, 19 deletions
diff --git a/community/py3-pygit2/APKBUILD b/community/py3-pygit2/APKBUILD
index bcdb1ddb356..1e3a5c809ce 100644
--- a/community/py3-pygit2/APKBUILD
+++ b/community/py3-pygit2/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-pygit2
_pkgname=pygit2
-pkgver=1.2.0
+pkgver=1.2.1
pkgrel=0
pkgdesc="Python bindings for libgit2"
url="https://github.com/libgit2/pygit2"
@@ -12,9 +12,7 @@ license="GPL-2.0 WITH GCC-exception-2.0"
depends="py3-cffi py3-six"
makedepends="python3-dev py3-setuptools libgit2-dev"
checkdepends="py3-pytest py3-hypothesis py3-cached-property"
-source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
- skip-failing-test-on-s390x.patch
- "
+source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-pygit" # Backward compat
@@ -32,5 +30,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="44ed29f8d10f4f784e6192b79f6a3924d64b22297cf335e9d005be578c3e0c77999855db802f71d2fcb5c053593ea2e9711e2cd191b3e185ec01c0d49e2ae1c6 pygit2-1.2.0.tar.gz
-1bd1ed146ebfae659c20aa641f795606a32e485fab13a71db12345082a18a9de9f0129d8375ffb6bf8616c906c59d0b25fb440e1f00bcd56e3e10b9aac3363fd skip-failing-test-on-s390x.patch"
+sha512sums="2491892e50d9298d68c2f90b3c4b23c87e51995ccc29e285eb2f868f5e34d2568d5f554818203bf2c735179aeb197e3b7aba1be88e72a6526812e3ee2e0b4348 pygit2-1.2.1.tar.gz"
diff --git a/community/py3-pygit2/skip-failing-test-on-s390x.patch b/community/py3-pygit2/skip-failing-test-on-s390x.patch
deleted file mode 100644
index 19d816f4eac..00000000000
--- a/community/py3-pygit2/skip-failing-test-on-s390x.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/test/test_patch.py b/test/test_patch.py
-index b115e69..6aaa494 100644
---- a/test/test_patch.py
-+++ b/test/test_patch.py
-@@ -181,7 +181,7 @@ class PatchTest(utils.RepoTestCase):
- [line for line in patch.text.splitlines() if line.startswith(" ")]
- )
-
-- assert context_count == 0
-+# assert context_count == 0
-
- def test_patch_create_blob_blobs(self):
- old_blob = self.repo[self.repo.create_blob(BLOB_OLD_CONTENT)]