aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2023-03-13 07:40:07 +0000
committeralice <alice@ayaya.dev>2023-03-14 11:23:55 +0000
commit24fcae9ad84bc3247e2fc25218d06fe7f015bd1b (patch)
treebd944278543277a7395f953868048641fed31dfb
parent5188f4ab48e05545ad3cc1ecffc3c81a00133b4e (diff)
testing/perl-code-tidyall-plugin-clangformat: new aport
-rw-r--r--testing/perl-code-tidyall-plugin-clangformat/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/perl-code-tidyall-plugin-clangformat/APKBUILD b/testing/perl-code-tidyall-plugin-clangformat/APKBUILD
new file mode 100644
index 00000000000..0f111dd40d1
--- /dev/null
+++ b/testing/perl-code-tidyall-plugin-clangformat/APKBUILD
@@ -0,0 +1,36 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=perl-code-tidyall-plugin-clangformat
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Code-TidyAll-Plugin-ClangFormat
+pkgver=0.0.2
+pkgrel=0
+pkgdesc="Perl module for Code-TidyAll-Plugin-ClangFormat"
+url="https://metacpan.org/release/Code-TidyAll-Plugin-ClangFormat/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-code-tidyall perl-moo perl-path-tiny"
+makedepends="perl-dev perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Code-TidyAll-Plugin-ClangFormat-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install --destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+8aa9c51be97c35d4c1a673cffb78388c2b77c87a49cf7628f564ff7c1d011515b4d98fb8c3038e6c9253aed7839c713840573bc8d18aa48a24f2a6380053d3bd Code-TidyAll-Plugin-ClangFormat-0.0.2.tar.gz
+"