aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Worthington <nicolaw@tfb.net>2018-09-09 22:08:55 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 11:50:03 -0300
commit2514f20ef872b4e491e4571db343336c6f4e25a4 (patch)
tree1d08f5f4e0165db78a857fba4a5cb15d2f588e6b
parent3fb7ffe9ba9287fda7a236e221b5ab5150883c14 (diff)
testing/blip: new aport
https://github.com/neechbear/blip Bash Library for Indolent Programmers
-rw-r--r--testing/blip/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/blip/APKBUILD b/testing/blip/APKBUILD
new file mode 100644
index 00000000000..dc428ed925c
--- /dev/null
+++ b/testing/blip/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Nicola Worthington <nicolaw@tfb.net>
+# Maintainer: Nicola Worthington <nicolaw@tfb.net>
+pkgname=blip
+pkgver=0.10
+pkgrel=0
+pkgdesc="Bash Library for Indolent Programmers"
+options="!check" # 2 Tests fail
+url="https://nicolaw.uk/blip"
+arch="noarch"
+license="MIT"
+depends="bash bc grep"
+subpackages="$pkgname-doc"
+source="https://github.com/neechbear/blip/releases/download/v${pkgver}/blip-${pkgver}.tar.gz"
+
+check() {
+ make test
+}
+
+package() {
+ make install prefix="/usr" DESTDIR="$pkgdir"
+}
+
+sha512sums="59a414d3ae8008bdde5b54a9789014781201381970e0288030a2b86709a43d81367c9c78bffb989af04c138dcfaa045d7e840d3f69ff71ac605c06d2e7da290a blip-0.10.tar.gz"