aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2023-09-19 12:41:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2023-09-21 20:05:59 +0000
commit25d87f81031b366bcc7ffd5d52aada4464564106 (patch)
tree7dc76332504ab28b5a61fa04d42e20df3e9953e7
parent26cc2a197044b502ad65d4fa5800384cefeacd4e (diff)
main/gettext: upgrade to 0.22.2
-rw-r--r--main/gettext/APKBUILD6
-rw-r--r--main/gettext/musl-realpath.patch45
2 files changed, 11 insertions, 40 deletions
diff --git a/main/gettext/APKBUILD b/main/gettext/APKBUILD
index 3160c84c2fe..2c15f8edf60 100644
--- a/main/gettext/APKBUILD
+++ b/main/gettext/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=gettext
-pkgver=0.22
+pkgver=0.22.2
pkgrel=0
pkgdesc="GNU locale utilities"
url="https://www.gnu.org/software/gettext/gettext.html"
@@ -87,8 +87,8 @@ _envsubst() {
}
sha512sums="
-c6368344aa4e0f6fd7c4a93023a5f7b377c7bb97b8ea688fd54f4c385c069d9ff27611d8763b1aed6328b6d3c4db7b34bd89bfbf6525ecaef11eb58434a4d4fa gettext-0.22.tar.xz
+c5c24eca1c7e8e242e6b993a39068dc281b84fda7f06e5020dc7fc10ac7de5bfcc476b7e94711723a7f82cc7f5a0845616ddd553078ee69690e3a146fc3f8ae5 gettext-0.22.2.tar.xz
31796534e40c1569b08cf48e25375ca1d0f439df8aa0d24283769d52a290e28522760128f11f5bd04217605974ae1fdee9557ec189ed32b11b2a45b4af3b0f4a cwd.patch
-593615f1d3a75e0fff1561b11e6363aacdc44045adf19c765e27360f256149e442643f40ef1ed781d4175e02dd9719871019e16b0c1393a124a8a87ef0cf75b0 musl-realpath.patch
+c423b7f5610f03af63ed5327801be47fecc1d3de66cb018b32d05179a62889156cefb6d302686e9ecd81421951a5aa5e4c5a7d911823fc41d4c52ad2387e0719 musl-realpath.patch
a16963f804ce4abe8480da211228f7b24a0715d6ef3ff7d5e5c58a1387d6c4260ee237864081b05b164f082ef199a592494ce691dd0c96c61978e4c451707c7a skip-tests-musl.patch
"
diff --git a/main/gettext/musl-realpath.patch b/main/gettext/musl-realpath.patch
index 05cb14f7530..0afd08b073c 100644
--- a/main/gettext/musl-realpath.patch
+++ b/main/gettext/musl-realpath.patch
@@ -1,40 +1,11 @@
-https://gitlab.alpinelinux.org/alpine/aports/-/issues/12295
-
-----
-test-canonicalize.c:339: assertion 'strcmp (result1, "/") == 0' failed
-Aborted (core dumped)
-FAIL test-canonicalize (exit status: 134)
-----
-
-diff --git a/gettext-tools/gnulib-tests/test-canonicalize-lgpl.c b/gettext-tools/gnulib-tests/test-canonicalize-lgpl.c
-index ff82981..17842e8 100644
---- a/gettext-tools/gnulib-tests/test-canonicalize-lgpl.c
-+++ b/gettext-tools/gnulib-tests/test-canonicalize-lgpl.c
-@@ -208,8 +208,8 @@ main (void)
- #ifndef __MVS__
- if (SAME_INODE (st1, st2))
- {
-- ASSERT (strcmp (result1, "/") == 0);
-- ASSERT (strcmp (result2, "/") == 0);
-+ ASSERT (strcmp (result1, "/") == 0 || strcmp (result1, "//") == 0);
-+ ASSERT (strcmp (result2, "/") == 0 || strcmp (result2, "//") == 0);
- }
- else
- #endif
--- a/gettext-tools/gnulib-tests/test-canonicalize.c
+++ b/gettext-tools/gnulib-tests/test-canonicalize.c
-@@ -336,10 +336,10 @@
+@@ -394,7 +394,7 @@
+ ASSERT (stat ("/", &st1) == 0);
ASSERT (stat ("//", &st2) == 0);
- if (SAME_INODE (st1, st2))
- {
-- ASSERT (strcmp (result1, "/") == 0);
-- ASSERT (strcmp (result2, "/") == 0);
-- ASSERT (strcmp (result3, "/") == 0);
-- ASSERT (strcmp (result4, "/") == 0);
-+ ASSERT (strcmp (result1, "/") == 0 || strcmp (result1, "//") == 0);
-+ ASSERT (strcmp (result2, "/") == 0 || strcmp (result2, "//") == 0);
-+ ASSERT (strcmp (result3, "/") == 0 || strcmp (result3, "//") == 0);
-+ ASSERT (strcmp (result4, "/") == 0 || strcmp (result4, "//") == 0);
- }
- else
- {
+ bool same = psame_inode (&st1, &st2);
+-#if defined __MVS__ || defined MUSL_LIBC
++#if defined __MVS__
+ /* On IBM z/OS and musl libc, "/" and "//" both canonicalize to
+ themselves, yet they both have st_dev == st_ino == 1. */
+ same = false;