aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-05-31 02:06:28 +0000
committerpsykose <alice@ayaya.dev>2023-05-31 04:07:07 +0200
commit25d9aff813d09f29553efe26931cbf2c2c585169 (patch)
tree628ddb5769e421860ec484607a10024f9b6f448b
parent931d60e016cbe1e233db590f6bba6183273b70ec (diff)
main/samurai: use O2
this makes it ~20% faster to parse a .ninja file you don't normally notice this, but the chromium one takes multiple seconds for any action
-rw-r--r--main/samurai/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/samurai/APKBUILD b/main/samurai/APKBUILD
index 30c64108dde..89c7097a2f5 100644
--- a/main/samurai/APKBUILD
+++ b/main/samurai/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=samurai
pkgver=1.2
-pkgrel=3
+pkgrel=4
pkgdesc="ninja-compatible build tool written in C"
url="https://github.com/michaelforney/samurai"
arch="all"
@@ -22,7 +22,7 @@ provider_priority=10
# - CVE-2021-30219
build() {
- make
+ make CFLAGS="$CFLAGS -O2"
}
package() {