aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2021-04-15 09:54:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2021-04-15 11:57:03 +0200
commit25fb7ad36f1512a3954c6058df68e013754092a4 (patch)
tree0dd592e436b20d4b12056dedae418e909cacf642
parent0f74849ab77c0e032e147b85c0f0e2600d41a833 (diff)
testing/vim-sleuth: reintroduce aport
vim: Heuristically set buffer options https://github.com/tpope/vim-sleuth originally added in commit edc3a2b27509 (testing/vim-sleuth: new aport) and then removed during cleanup in commit b6af1e02efe5 (testing/[multiple]: move unmaintained packages)
-rw-r--r--testing/vim-sleuth/APKBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/vim-sleuth/APKBUILD b/testing/vim-sleuth/APKBUILD
new file mode 100644
index 00000000000..4a18bcd807a
--- /dev/null
+++ b/testing/vim-sleuth/APKBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=vim-sleuth
+pkgver=1.2
+pkgrel=0
+pkgdesc="vim: Heuristically set buffer options"
+url="https://github.com/tpope/vim-sleuth"
+arch="noarch"
+license="Vim"
+depends="vim"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tpope/vim-sleuth/archive/v$pkgver.tar.gz"
+
+package() {
+ local _vimver=$( vim --version | sed -E -n '1s/.*(\d+)\.(\d+).*/\1\2/p')
+ mkdir -p "$pkgdir"/usr/share/vim/vim$_vimver
+ cp -r plugin doc "$pkgdir"/usr/share/vim/vim$_vimver/
+}
+
+sha512sums="7ba960a0cebf6c7eed877f3bca5435905c27c8d486a00bbd7dc34f46c841660e9557f26f368b8efb86cd2fcd6739c230fe3737c66064436aa114c9a9235a3332 vim-sleuth-1.2.tar.gz"