aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-10 22:09:43 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-10 22:27:55 +0000
commit2657397f5b02eb0c1c9cf7a99cd254859bdf2f99 (patch)
tree05f87f82c5cd0a41fe5c89030a5ed945d72c3365
parent4f908b89344809c140eb8b8492c3ad284611d4e4 (diff)
community/perl-file-remove: move to main and define check
moved due to perl-module-install
-rw-r--r--main/perl-file-remove/APKBUILD (renamed from community/perl-file-remove/APKBUILD)17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/perl-file-remove/APKBUILD b/main/perl-file-remove/APKBUILD
index 17cbaf034c1..c73558660bc 100644
--- a/community/perl-file-remove/APKBUILD
+++ b/main/perl-file-remove/APKBUILD
@@ -9,28 +9,33 @@ url="http://search.cpan.org/dist/File-Remove/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}