aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2022-04-09 18:23:16 +0200
committeralice <alice@ayaya.dev>2022-06-20 15:08:54 +0000
commit2adaec430bf333d28d878eed2d8a56df41af27a2 (patch)
tree2c5de00b1989ee39f2f05987d22abf793e04b7e1
parent6596e5412d6162ed1e98b547109c50e44078d619 (diff)
main/libical: upgrade to 3.0.14
-rw-r--r--main/libical/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/libical/APKBUILD b/main/libical/APKBUILD
index 2e7ce3ec687..157c2d2807e 100644
--- a/main/libical/APKBUILD
+++ b/main/libical/APKBUILD
@@ -2,20 +2,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libical
pkgver=3.0.14
-pkgrel=0
+pkgrel=1
pkgdesc="Reference implementation of the iCalendar format"
url="https://libical.github.io/libical/"
arch="all"
license="LGPL-2.1-only OR MPL-2.0"
depends_dev="libxml2-dev gobject-introspection-dev"
-makedepends="perl cmake vala glib-dev icu-dev $depends_dev"
+makedepends="perl cmake vala glib-dev icu-dev samurai $depends_dev"
checkdepends="tzdata py3-gobject3"
subpackages="$pkgname-dev"
source="https://github.com/libical/libical/releases/download/v$pkgver/libical-$pkgver.tar.gz"
-
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -28,7 +27,7 @@ build() {
check() {
cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E regression
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(icalrecurtest|icalrecurtest_r)'
}
package() {