aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-21 22:50:43 -0300
committerRasmus Thomsen <oss@cogitri.dev>2020-04-22 12:20:27 +0000
commit2bae94edd4551f5150ab22c334aefe7072d2c900 (patch)
tree492c6301b1c63318720adf0097279db9c9e5f824
parentda0db2dd1bbb57cc4dfd3ca1aa6bc2feda6f45c3 (diff)
community/gnome-control-center: add notice on geoclue respecting privacy
-rw-r--r--community/gnome-control-center/APKBUILD14
-rw-r--r--community/gnome-control-center/README.alpine14
-rw-r--r--community/gnome-control-center/gnome-control-center.pre-install21
l---------community/gnome-control-center/gnome-control-center.pre-upgrade1
4 files changed, 46 insertions, 4 deletions
diff --git a/community/gnome-control-center/APKBUILD b/community/gnome-control-center/APKBUILD
index 430b549eca9..19e6c07c349 100644
--- a/community/gnome-control-center/APKBUILD
+++ b/community/gnome-control-center/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-control-center
pkgver=3.36.1
-pkgrel=0
+pkgrel=1
pkgdesc="GNOME control center"
url="https://gitlab.gnome.org/GNOME/gnome-control-center"
# limited by gnome-online-accounts
@@ -43,8 +43,11 @@ makedepends="
cheese-dev
ibus-dev"
options="!check" # needs unpackaged py-dbusmock
-subpackages="$pkgname-dev $pkgname-lang $pkgname-dbg"
-source="https://download.gnome.org/sources/gnome-control-center/${pkgver%.*}/gnome-control-center-$pkgver.tar.xz"
+install="$pkgname.pre-install $pkgname.pre-upgrade"
+subpackages="$pkgname-dev $pkgname-lang $pkgname-dbg $pkgname-doc"
+source="https://download.gnome.org/sources/gnome-control-center/${pkgver%.*}/gnome-control-center-$pkgver.tar.xz
+ README.alpine
+ "
build() {
meson \
@@ -68,6 +71,9 @@ package() {
mkdir -p "$pkgdir"/usr/lib
mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib
+
+ install -Dm0644 "$srcdir"/README.alpine -t "$pkgdir"/usr/share/doc/"$pkgname"
}
-sha512sums="6f0588623bf8b9de151e7dc04a18c41c1864836d3d62d78ada45e7735c100f2124819b74864dbdd50039368346446782f2b42005503f0978fa95adca8134e5d9 gnome-control-center-3.36.1.tar.xz"
+sha512sums="6f0588623bf8b9de151e7dc04a18c41c1864836d3d62d78ada45e7735c100f2124819b74864dbdd50039368346446782f2b42005503f0978fa95adca8134e5d9 gnome-control-center-3.36.1.tar.xz
+350aa443149c71851ad4de0976c7fc5cb626ba0c57a8d41e6ef80da1c65ed84a4dfa2483ae92630a3b611c4bfa9360ded82b55e8cd0e3907294c025e4f6b1671 README.alpine"
diff --git a/community/gnome-control-center/README.alpine b/community/gnome-control-center/README.alpine
new file mode 100644
index 00000000000..d5967ee0805
--- /dev/null
+++ b/community/gnome-control-center/README.alpine
@@ -0,0 +1,14 @@
+Note that the privacy settings in GNOME settings isn't respected by geoclue
+for applications that are not sandboxed (running in flatpak), so it will
+provide location information to any application that asks it, and will not
+show any applications BUT ones run via flatpak
+
+This is working as intended by geoclue upstream[1] and applications that
+are not sandboxed have other methods of acquiring information provided
+by geoclue
+
+GNOME settings also tracks what they want to do with their privacy panel
+in regards to the problem above here[2]
+
+[1] https://gitlab.freedesktop.org/geoclue/geoclue/issues/111
+[2] https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/805
diff --git a/community/gnome-control-center/gnome-control-center.pre-install b/community/gnome-control-center/gnome-control-center.pre-install
new file mode 100644
index 00000000000..0bbbc3314a2
--- /dev/null
+++ b/community/gnome-control-center/gnome-control-center.pre-install
@@ -0,0 +1,21 @@
+#!/bin/sh
+cat << __EOF__
+*
+* Note that the privacy settings in GNOME settings isn't respected by geoclue
+* for applications that are not sandboxed (running in flatpak), so it will
+* provide location information to any application that asks it, and will not
+* show any applications BUT ones run via flatpak
+*
+* This is working as intended by geoclue upstream[1] and applications that
+* are not sandboxed have other methods of acquiring information provided
+* by geoclue
+*
+* GNOME settings also tracks what they want to do with their privacy panel
+* in regards to the problem above here[2]
+*
+* [1] https://gitlab.freedesktop.org/geoclue/geoclue/issues/111
+* [2] https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/805
+*
+__EOF__
+
+exit 0
diff --git a/community/gnome-control-center/gnome-control-center.pre-upgrade b/community/gnome-control-center/gnome-control-center.pre-upgrade
new file mode 120000
index 00000000000..77c4e93cb5c
--- /dev/null
+++ b/community/gnome-control-center/gnome-control-center.pre-upgrade
@@ -0,0 +1 @@
+gnome-control-center.pre-install \ No newline at end of file