aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKozak Ivan <kozak-iv@yandex.ru>2014-01-29 22:54:48 +0400
committerNatanael Copa <ncopa@alpinelinux.org>2014-01-30 07:56:49 +0000
commit2c379b9391c84f7ea89197442109e800c12189b0 (patch)
tree4ce892bcdf7df8b170930c33169c1d2891869445
parenta3bfcd42947ab0613290a8368a4b38fb05f4e3ef (diff)
testing/dovecot-antispam-plugin: new aport
-rw-r--r--testing/dovecot-antispam-plugin/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/dovecot-antispam-plugin/APKBUILD b/testing/dovecot-antispam-plugin/APKBUILD
new file mode 100644
index 00000000000..755355b6f17
--- /dev/null
+++ b/testing/dovecot-antispam-plugin/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Kozak Ivan <kozak-iv@yandex.ru>
+# Maintainer: Kozak Ivan <kozak-iv@yandex.ru>
+pkgname=dovecot-antispam-plugin
+pkgver=51
+pkgrel=0
+pkgdesc="Integrates DSPAM into dovecot IMAP server. Mercurial Version for dovecot >= 2.1"
+url="http://hg.dovecot.org/dovecot-antispam-plugin/"
+arch="all"
+license="GPL"
+depends="dovecot"
+depends_dev="dovecot-dev mercurial autoconf automake gawk"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source=""
+
+_hgroot="http://hg.dovecot.org/dovecot-antispam-plugin"
+_hgrepo="dovecot-antispam-plugin"
+_builddir="$srcdir/$_hgrepo"
+
+prepare() {
+ cd "$srcdir"
+ msg "Connecting to Mercurial server..."
+
+ if [ -d "$_hgrepo" ]; then
+ cd "$_hgrepo"
+ hg pull -r 51 -u
+ msg "The local files are updated."
+ else
+ hg clone -r 51 "$_hgroot" "$_hgrepo"
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh || return 1
+ ./configure --prefix=/usr --with-dovecot=/usr/lib/dovecot || return 1
+ sed -i -e 's/install -o/install -D -o/' -e 's|$(INSTALLDIR)/|$(INSTALLDIR)/$(LIBRARY_NAME)|' Makefile || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+