aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-05-25 09:32:36 +0000
committerpsykose <alice@ayaya.dev>2023-05-25 11:32:37 +0200
commit2cbd7ef578c3466ebbf91269ad5b7b55eb363d90 (patch)
tree23dbde9e92c019f0fcaa5e0b18aa6a292eb9ed49
parentba42a4b24164658e0b179cb21d7c6f64da3b3994 (diff)
community/chromium: backport webrtc fix
-rw-r--r--community/chromium/APKBUILD4
-rw-r--r--community/chromium/pipewire-fcntl-call.patch18
2 files changed, 21 insertions, 1 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index a3b3c8d59b8..3ad0c9dfeac 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=chromium
pkgver=113.0.5672.126
-pkgrel=1
+pkgrel=2
# https://source.chromium.org/chromium/chromium/src/+/main:third_party/test_fonts/test_fonts.tar.gz.sha1
# (for the given version, when it changes)
_testfonts=336e775eec536b2d785cc80eff6ac39051931286
@@ -131,6 +131,7 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/chrom
no-execinfo.patch
no-mallinfo.patch
no-res-ninit-nclose.patch
+ pipewire-fcntl-call.patch
pvalloc.patch
quiche-array.patch
scoped-file-no-close.patch
@@ -830,6 +831,7 @@ e7163ac5810ac85366cef2447412287c856e3d67c6b77f219a6e5a418b1965b98e449c409424ad07
8cc774e8d84e434960222c0497ad8193ae35c0732f98d3282d5fd4b4930f914809eec97832c199517ca89ca6b9d1d011db5ce533c40c68ce5fa464609d131a23 no-execinfo.patch
b5479874d125ee95a311295f227f8881a83023ec34fded7a6160b3ae32ea3ba0f2b833a9fb264c57f3d22746b6d8b00bdc8eb2ff86c43c412d6d3b55ae15b16b no-mallinfo.patch
e4c4e5bc6f828f9c883dd418c0ba01887949c29c311f76206a1ec29f620b0c0ba0452949dc2778a9c46ea066405857536964a36436a68eecf7da7952736333cf no-res-ninit-nclose.patch
+154af2b35fdf9d602bef8110404a200ebb59eafecf132dcfb57228dd4d8aa93b99afe81095ef736defc0f20212c3ac44f6189ecd9c2d8107cbe788eb1ad436e2 pipewire-fcntl-call.patch
95bd9dd200658f4ca458e53c77a86da50104905db29b0241d701ecbee1573a7dcf14c409d62b7d01f8ee6cc3511dbb79677754b7145ca917c37894f5c853cfb9 pvalloc.patch
86f612dd2b39602984a75b1b11c2ab8bc8cc6b4e78fae998570a777a6901ae45fdcdb22e46dd006dab703a0674e64c72cf8120af2dc5b9e78004f402c7e65358 quiche-array.patch
8c33808ede31dd3b8eb951991e034751949756c4e6c2cd0e19823e95fddf5f9d94424bbd73ffe6dd965df2b0887fc5c42ab8a97c64b553d47662e90651b84f13 scoped-file-no-close.patch
diff --git a/community/chromium/pipewire-fcntl-call.patch b/community/chromium/pipewire-fcntl-call.patch
new file mode 100644
index 00000000000..e123eb66564
--- /dev/null
+++ b/community/chromium/pipewire-fcntl-call.patch
@@ -0,0 +1,18 @@
+Patch-Source: https://webrtc-review.googlesource.com/c/src/+/305120
+--
+diff --git a/modules/desktop_capture/linux/wayland/shared_screencast_stream.cc b/modules/desktop_capture/linux/wayland/shared_screencast_stream.cc
+index 5878180..b2ad7ad 100644
+--- a/third_party/webrtc/modules/desktop_capture/linux/wayland/shared_screencast_stream.cc
++++ b/third_party/webrtc/modules/desktop_capture/linux/wayland/shared_screencast_stream.cc
+@@ -452,8 +452,8 @@
+ PipeWireThreadLoopLock thread_loop_lock(pw_main_loop_);
+
+ if (fd >= 0) {
+- pw_core_ = pw_context_connect_fd(
+- pw_context_, fcntl(fd, F_DUPFD_CLOEXEC), nullptr, 0);
++ pw_core_ = pw_context_connect_fd(
++ pw_context_, fcntl(fd, F_DUPFD_CLOEXEC, 0), nullptr, 0);
+ } else {
+ pw_core_ = pw_context_connect(pw_context_, nullptr, 0);
+ }
+