aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2021-08-20 00:30:25 +0200
committerJakub Jirutka <jakub@jirutka.cz>2021-08-20 00:30:25 +0200
commit2cfb106c3cfd731dc8b8989ff112aba979513a51 (patch)
tree8dc771e7aa0204a72c5ea1bc428b44f3d8b6f383
parentcc03d5913a24b3ffa50d61e384734c5fafd63418 (diff)
testing/mimalloc2: disable on aarch64 due to test failure
>>> mimalloc2: Testing debug build Test project /home/buildozer/aports/testing/mimalloc2/src/mimalloc-2.0.2/out/debug Start 1: test_api, 1/2 Test #1: test_api, ........................***Exception: SegFault 2.13 sec test: malloc-zero... Start 2: test_stress, 2/2 Test #2: test_stress, .....................Subprocess aborted***Exception: 0.00 sec Using 32 threads with a 25% load-per-thread and 50 iterations mimalloc: assertion failed: at "/home/buildozer/aports/testing/mimalloc2/src/mimalloc-2.0.2/src/alloc.c":71, mi_heap_malloc_small assertion: "heap->thread_id == 0 || heap->thread_id == _mi_thread_id()"
-rw-r--r--testing/mimalloc2/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/mimalloc2/APKBUILD b/testing/mimalloc2/APKBUILD
index 3785af30e8c..b3f1ee20d40 100644
--- a/testing/mimalloc2/APKBUILD
+++ b/testing/mimalloc2/APKBUILD
@@ -8,8 +8,8 @@ pkgrel=0
_pkgdesc="A compact general purpose allocator with excellent performance"
pkgdesc="$_pkgdesc (in secure mode)"
url="https://github.com/microsoft/mimalloc"
-# arm*: tests fail
-arch="all !armhf !armv7"
+# aarch64,arm*: tests fail
+arch="all !aarch64 !armhf !armv7"
license="MIT"
makedepends="cmake"
provides="mimalloc=$pkgver-r$pkgrel"