aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-07-03 14:03:33 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-07-11 06:58:59 +0000
commit2e1868897095af39e7278145c668e78321a250de (patch)
treed56a8248f2d730edc2d811fd798450edf78be5ef
parentc60d651f30982c74cb0ed3bbc6085ce68b7fa251 (diff)
testing/py3-threadpoolctl: new aport
-rw-r--r--testing/py3-threadpoolctl/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-threadpoolctl/APKBUILD b/testing/py3-threadpoolctl/APKBUILD
new file mode 100644
index 00000000000..8a559c476f0
--- /dev/null
+++ b/testing/py3-threadpoolctl/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-threadpoolctl
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Python helpers to limit the number of threads used in native libraries"
+url="https://github.com/joblib/threadpoolctl"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="https://pypi.python.org/packages/source/t/threadpoolctl/threadpoolctl-$pkgver.tar.gz"
+builddir="$srcdir/threadpoolctl-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ # HACK so calls to "python" will get what we want
+ ln -s /usr/bin/python3 python
+ export PATH="$(pwd):$PATH"
+ pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ad2a514fd4e37f6f9127d2eebfa99a4e2cc5d709c7faa8ce75940772c1034772d774b76caa9359ee01a2aa29748458b9475c49f2b2ae91147f5c9b34054b771c threadpoolctl-2.1.0.tar.gz"