aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-11-24 20:21:41 +0100
committerBart Ribbers <bribbers@disroot.org>2020-12-14 10:30:52 +0100
commit2fbf89d652c30d23ad16e0b94c74689ffb8dc9ac (patch)
treeef83aa4f298d04335f779aaa63a4eb5d0e83e9ba
parent211a7af7fb70c76c84868401fe3c915f3a8c024d (diff)
downloadaports-2fbf89d652c30d23ad16e0b94c74689ffb8dc9ac.tar.gz
aports-2fbf89d652c30d23ad16e0b94c74689ffb8dc9ac.tar.bz2
aports-2fbf89d652c30d23ad16e0b94c74689ffb8dc9ac.tar.xz
community/qt5-qtwebkit: rebuild against Qt 5.15.2
-rw-r--r--community/qt5-qtwebkit/APKBUILD6
-rw-r--r--community/qt5-qtwebkit/fix-build-with-bison3.7.patch46
2 files changed, 50 insertions, 2 deletions
diff --git a/community/qt5-qtwebkit/APKBUILD b/community/qt5-qtwebkit/APKBUILD
index 2313ee5aea5..36c3a3855e1 100644
--- a/community/qt5-qtwebkit/APKBUILD
+++ b/community/qt5-qtwebkit/APKBUILD
@@ -2,7 +2,7 @@
pkgname=qt5-qtwebkit
pkgver=5.212.0_alpha4
_pkgver=${pkgver/_/-}
-pkgrel=12
+pkgrel=13
pkgdesc="Qt5 - QtWebKit components"
url="https://www.qt.io/developers/"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -35,6 +35,7 @@ subpackages="$pkgname-dev"
source="https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-$_pkgver/qtwebkit-$_pkgver.tar.xz
musl-mcontext.patch
+ fix-build-with-bison3.7.patch
"
builddir="$srcdir/qtwebkit-$_pkgver"
@@ -60,4 +61,5 @@ package() {
}
sha512sums="33f11270bd030599beff9c1983a6c5ff2d61f407cc8a6825f7f405d46f9184c720fc7f60c7359f08f828db96a2170092875066a0d5c0a21ff09bc48a2603fbf6 qtwebkit-5.212.0-alpha4.tar.xz
-11f6b4b5101f5e89917062483c0d55c4180dc4b8107bb3f6ad92ed4e56361ef1b604909056b383313c4072b1229dc9f6606ceacdd84efc1dc80dd1151294b195 musl-mcontext.patch"
+11f6b4b5101f5e89917062483c0d55c4180dc4b8107bb3f6ad92ed4e56361ef1b604909056b383313c4072b1229dc9f6606ceacdd84efc1dc80dd1151294b195 musl-mcontext.patch
+cf21eff51e1026f4e506724a512b9925d4619909f5924bf01055244817ec9594e9d3ce105b510cd28ecce4772d122d1393fb7273501e20e16749f43282a3200b fix-build-with-bison3.7.patch"
diff --git a/community/qt5-qtwebkit/fix-build-with-bison3.7.patch b/community/qt5-qtwebkit/fix-build-with-bison3.7.patch
new file mode 100644
index 00000000000..de3bbcfc3ef
--- /dev/null
+++ b/community/qt5-qtwebkit/fix-build-with-bison3.7.patch
@@ -0,0 +1,46 @@
+From d92b11fea65364fefa700249bd3340e0cd4c5b31 Mon Sep 17 00:00:00 2001
+From: Dmitry Shachnev <mitya57@gmail.com>
+Date: Tue, 4 Aug 2020 21:04:06 +0300
+Subject: [PATCH] Let Bison generate the header directly, to fix build with
+ Bison 3.7
+
+Starting with Bison 3.7, the generated C++ file #include's the header
+by default, instead of duplicating it. So we should not delete it.
+
+Remove the code to add #ifdef guards to the header, since Bison adds
+them itself since version 2.6.3.
+---
+ Source/WebCore/css/makegrammar.pl | 21 +--------------------
+ 1 file changed, 1 insertion(+), 20 deletions(-)
+
+diff --git a/Source/WebCore/css/makegrammar.pl b/Source/WebCore/css/makegrammar.pl
+index 5d63b08102eb..9435701c7061 100644
+--- a/Source/WebCore/css/makegrammar.pl
++++ b/Source/WebCore/css/makegrammar.pl
+@@ -73,25 +73,6 @@
+ }
+
+ my $fileBase = File::Spec->join($outputDir, $filename);
+-my @bisonCommand = ($bison, "-d", "-p", $symbolsPrefix, $grammarFilePath, "-o", "$fileBase.cpp");
++my @bisonCommand = ($bison, "--defines=$fileBase.h", "-p", $symbolsPrefix, $grammarFilePath, "-o", "$fileBase.cpp");
+ push @bisonCommand, "--no-lines" if $^O eq "MSWin32"; # Work around bug in bison >= 3.0 on Windows where it puts backslashes into #line directives.
+ system(@bisonCommand) == 0 or die;
+-
+-open HEADER, ">$fileBase.h" or die;
+-print HEADER << "EOF";
+-#ifndef CSSGRAMMAR_H
+-#define CSSGRAMMAR_H
+-EOF
+-
+-open HPP, "<$fileBase.cpp.h" or open HPP, "<$fileBase.hpp" or die;
+-while (<HPP>) {
+- print HEADER;
+-}
+-close HPP;
+-
+-print HEADER "#endif\n";
+-close HEADER;
+-
+-unlink("$fileBase.cpp.h");
+-unlink("$fileBase.hpp");
+-