aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-03-23 06:54:17 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-03-23 06:54:17 +0000
commit3014d7a2fa056a1052dcd0d96882d54f5d9729f8 (patch)
treef02e78911303d2bd48264973c9dc10c4d6becc3b
parentb446d1c81383362cbea72bd77a93b5e6cd878e89 (diff)
main/boost: fix FTBFS on mips64
-rw-r--r--main/boost/APKBUILD4
-rw-r--r--main/boost/boost-fiber-mips64-ftbfs.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index 2f323f8e64a..7240f417183 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -15,6 +15,7 @@ source="https://dl.bintray.com/boostorg/release/$pkgver/source/boost_$_pkgver.ta
boost-1.57.0-python-abi_letters.patch
boost-1.57.0-python-libpython_dep.patch
0001-revert-cease-dependence-on-range.patch
+ boost-fiber-mips64-ftbfs.patch
"
builddir="$srcdir/${pkgname}_$_pkgver"
@@ -178,4 +179,5 @@ _pyversion() {
sha512sums="63bbd1743e7c904b2e69fdc2eafd1c2a8a30fd70d960dcd366059d0100f000cb605d56cbd9397bb18421631f1c9552a772c434d0f0caddbe56302273f51fd1f6 boost_1_72_0.tar.bz2
d96d4d37394a31764ed817d0bc4a99cffa68a75ff1ecfd4417b9e1e5ae2c31a96ed24f948c6f2758ffdac01328d2402c4cf0d33a37107e4f5f721e636daebd66 boost-1.57.0-python-abi_letters.patch
132c4b62815d605c2d3c9038427fa4f422612a33711d47b2862f2311516af8a371d6b75bf078a7bffe20be863f8d21fb9fe74dc1a1bac3a10d061e9768ec3e02 boost-1.57.0-python-libpython_dep.patch
-9b53d2fe2dddd592e43db03c26fadd6c07d4c45a980ae4c775b7a914346a3914f6e0c3ef42dad5e2ea4568afb86c9967e09444ff609cfba1e1d39f4980b22ad6 0001-revert-cease-dependence-on-range.patch"
+9b53d2fe2dddd592e43db03c26fadd6c07d4c45a980ae4c775b7a914346a3914f6e0c3ef42dad5e2ea4568afb86c9967e09444ff609cfba1e1d39f4980b22ad6 0001-revert-cease-dependence-on-range.patch
+054f475a3a89d550c374a0a80cda580adf5d12e75a44166c9cddf7247e603285c85b428c3c799f00cdd8e4af3fc690d9cef05320ac2fbf2a07dae9827d4bd647 boost-fiber-mips64-ftbfs.patch"
diff --git a/main/boost/boost-fiber-mips64-ftbfs.patch b/main/boost/boost-fiber-mips64-ftbfs.patch
new file mode 100644
index 00000000000..bde053ff7f9
--- /dev/null
+++ b/main/boost/boost-fiber-mips64-ftbfs.patch
@@ -0,0 +1,13 @@
+Roughly equivalent to upstream 5f7cda29add367c5381775a314ec9f90e311457a.
+
+--- a/boost/fiber/detail/cpu_relax.hpp
++++ b/boost/fiber/detail/cpu_relax.hpp
+@@ -47,7 +47,7 @@ namespace detail {
+ # else
+ # define cpu_relax() asm volatile ("nop" ::: "memory");
+ # endif
+-#elif BOOST_ARCH_MIPS
++#elif BOOST_ARCH_MIPS && (__mips_isa_rev > 1)
+ # define cpu_relax() asm volatile ("pause" ::: "memory");
+ #elif BOOST_ARCH_PPC
+ // http://code.metager.de/source/xref/gnu/glibc/sysdeps/powerpc/sys/platform/ppc.h