aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-19 23:43:44 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-19 23:57:52 +0100
commit305b20bcbe18d69fc4408a0086df9fa20207b4dc (patch)
tree7a60e891843cb75ce0eddcef799ad2c01f38d476
parent468c3f5f4552fa40fd11a66ed01c7804002bfbe7 (diff)
main/rsyslog: use py3-docutils
-rw-r--r--main/rsyslog/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/rsyslog/APKBUILD b/main/rsyslog/APKBUILD
index 68f2452b487..71907c7cb20 100644
--- a/main/rsyslog/APKBUILD
+++ b/main/rsyslog/APKBUILD
@@ -6,7 +6,7 @@
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=rsyslog
pkgver=8.1910.0
-pkgrel=0
+pkgrel=1
pkgdesc="Enhanced multi-threaded syslogd with database support and more."
url="https://www.rsyslog.com/"
arch="all !s390x" # limited by czmq
@@ -31,7 +31,7 @@ makedepends="
mariadb-connector-c-dev
net-snmp-dev
postgresql-dev
- py-docutils
+ py3-docutils
rabbitmq-c-dev
util-linux-dev
zlib-dev
@@ -91,7 +91,8 @@ done
# - CVE-2019-17042
build() {
- cd "$builddir"
+ ln -s /usr/bin/rst2man-3 rst2man
+ export PATH="$PATH":.
./configure \
--build=$CBUILD \
@@ -143,8 +144,6 @@ build() {
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
# Remove lib that is used only for testing.