aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Martin <dev@ayakael.net>2022-09-12 21:38:55 -0400
committerpsykose <alice@ayaya.dev>2022-10-05 16:35:01 +0200
commit3071ebe356b4abde870fcfe0c10e508261a4d629 (patch)
treee871b42dfa2a2ec9bed3bd1e4438ea0ef0a03a99
parent9a290fad384a26c3729a328aba4416260e7ca943 (diff)
downloadaports-3071ebe356b4abde870fcfe0c10e508261a4d629.tar.gz
aports-3071ebe356b4abde870fcfe0c10e508261a4d629.tar.bz2
aports-3071ebe356b4abde870fcfe0c10e508261a4d629.tar.xz
testing/hsxkpasswd: new aport
-rw-r--r--testing/hsxkpasswd/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/hsxkpasswd/APKBUILD b/testing/hsxkpasswd/APKBUILD
new file mode 100644
index 00000000000..ea6b049ca23
--- /dev/null
+++ b/testing/hsxkpasswd/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
+# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
+
+pkgname=hsxkpasswd
+pkgver=3.6
+pkgrel=0
+pkgdesc="Generate secure, memorable passwords inspired by XKCD and Password Haystacks"
+arch="noarch"
+url="https://www.bartbusschots.ie/s/publications/software/xkpasswd/"
+license="BSD-2-Clause"
+depends="
+ perl
+ perl-clone
+ perl-datetime
+ perl-file-homedir
+ perl-file-share
+ perl-json
+ perl-list-moreutils
+ perl-math-round
+ perl-readonly
+ perl-text-unidecode
+ perl-type-tiny
+ "
+makedepends="perl-module-build"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/bbusschots/hsxkpasswd/archive/v$pkgver.tar.gz"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null perl ./Build.PL
+ ./Build
+}
+
+check() {
+ PERL_MM_USE_DEFAULT=1 ./Build test
+}
+
+package() {
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="
+b93f3e8a209152def43040d05f27ed404ff7d596f69f831d1666cbd1dcb06907558b0e9ab9b256cfa25aa528fc92e13b816a0b8d476f4334a53f69b44612708f hsxkpasswd-3.6.tar.gz
+"