aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Correa Gómez <ablocorrea@hotmail.com>2021-11-06 14:52:55 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-11-07 21:45:45 +0000
commit3235e4a8d0f0023d0b670e94d395a38b7ede5e29 (patch)
treede5f52645626a62dbd03271bc48112c083b39bc5
parent5fbc9435894a5a7d29cf6ce2e0b0238a6e6a512e (diff)
community/gdm: rework makedepends to use only direct dependencies
There were multiple makedepends which are not required and some dependencies checked by the build which were not directly stated.
-rw-r--r--community/gdm/APKBUILD32
1 files changed, 27 insertions, 5 deletions
diff --git a/community/gdm/APKBUILD b/community/gdm/APKBUILD
index e1e88a7d2e2..53c29c0e017 100644
--- a/community/gdm/APKBUILD
+++ b/community/gdm/APKBUILD
@@ -8,11 +8,33 @@ url="https://wiki.gnome.org/Projects/GDM"
# s390x, mips64 and riscv64 blocked by polkit -> upower
arch="all !mips64 !s390x !riscv64"
license="GPL-2.0-or-later"
-depends="dconf linux-pam>=1.4 gnome-settings-daemon gnome-shell xorg-server
- xwayland xrdb gsettings-desktop-schemas gnome-session"
-makedepends="dconf-dev gnome-desktop-dev accountsservice-dev libcanberra-dev linux-pam-dev
- intltool itstool libxml2-utils libsm-dev iso-codes nss-dev upower-dev elogind-dev
- meson eudev-dev"
+depends="dbus
+ dconf
+ gnome-session
+ gnome-settings-daemon
+ gnome-shell
+ gsettings-desktop-schemas
+ linux-pam>=1.4
+ xorg-server
+ xrdb
+ xwayland
+"
+makedepends="accountsservice-dev
+ elogind-dev
+ eudev-dev
+ gettext
+ glib-dev
+ gtk+3.0-dev
+ itstool
+ libcanberra-dev
+ libsm-dev
+ libx11-dev
+ libxau-dev
+ libxcb-dev
+ libxdmcp-dev
+ linux-pam-dev
+ meson
+"
subpackages="$pkgname-dev $pkgname-lang $pkgname-openrc"
options="!check" # Causes circular dep with gnome-shell
source="https://download.gnome.org/sources/gdm/${pkgver%.*}/gdm-$pkgver.tar.xz