aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-11-21 14:46:28 +0100
committerJakub Jirutka <jakub@jirutka.cz>2022-11-22 00:02:58 +0100
commit32811adae7377ef1ae292587647ecfc90cbb12fb (patch)
tree7767221ed4b52a04eb4281967ae5c7b30067afaf
parent7c0e619e0f610fc6a7341f77c09b273d97327fe4 (diff)
downloadaports-32811adae7377ef1ae292587647ecfc90cbb12fb.tar.gz
aports-32811adae7377ef1ae292587647ecfc90cbb12fb.tar.bz2
aports-32811adae7377ef1ae292587647ecfc90cbb12fb.tar.xz
main/postgresql14: change to non-default and rebuild against libpq 15.1
-rw-r--r--main/postgresql14/APKBUILD6
-rw-r--r--main/postgresql14/fix-test-temp-schema-cleanup.patch14
2 files changed, 18 insertions, 2 deletions
diff --git a/main/postgresql14/APKBUILD b/main/postgresql14/APKBUILD
index 09401f050f5..2d1388d9247 100644
--- a/main/postgresql14/APKBUILD
+++ b/main/postgresql14/APKBUILD
@@ -3,11 +3,11 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
_pkgname=postgresql
pkgver=14.6
-pkgrel=0
+pkgrel=1
_majorver=${pkgver%%.*}
# Should this aport provide libpq* and libecpg*? true/false
# Exactly one postgresql aport must be the default one!
-_default_ver=true
+_default_ver=false
pkgname=$_pkgname$_majorver
pkgdesc="A sophisticated object-relational DBMS, version $_majorver"
url="https://www.postgresql.org/"
@@ -81,6 +81,7 @@ source="https://ftp.postgresql.org/pub/source/v$pkgver/postgresql-$pkgver.tar.bz
icu-collations-hack.patch
libpgport-pkglibdir.patch.txt
external-libpq.patch.txt
+ fix-test-temp-schema-cleanup.patch
pltcl_create_tables.sql
"
@@ -535,5 +536,6 @@ b0688d66fdd7d612c24d9aa69bdd80d30787d2d6409b4524c79b41797144fc743213460e6de9c536
0ebee9cf40a7e84e8eda3998c0dd0f7601d9288233411f45f9710fcafc5f4ca3e4a91e8e1b552cc4f4d2c0e8fa6512703b1094e501f132ea2842db0398e62934 icu-collations-hack.patch
f8ed2b7b96fd22cd87c982151e659d82bcae10033a97f403f7847fce6daa8fc580e998cfb3813af9cb59a12f0c6bcc276397c28b1fc48321eed8c7ba5f3f92ed libpgport-pkglibdir.patch.txt
6078defb3da67e7df96665cc130d32b69eebfcaf49d92eef368ea8eea8bb311fab56064c104bc97f53da9cd925301bef696b506af33e0b66d65bc6cd41ec7499 external-libpq.patch.txt
+4fcf6a4037fb5765ef5913aaa0d76557d6ef2334760c2d702571db5f613e348879a370a527bf40ff441864d1bbf7ca773b9e14a1c2615d659c27697a6aa316e6 fix-test-temp-schema-cleanup.patch
5c9bfd9e295dcf678298bf0aa974347a7c311d6e7c2aa76a6920fcb751d01fd1ab77abbec11f3c672f927ad9deaa88e04e370c0b5cd1b60087554c474b748731 pltcl_create_tables.sql
"
diff --git a/main/postgresql14/fix-test-temp-schema-cleanup.patch b/main/postgresql14/fix-test-temp-schema-cleanup.patch
new file mode 100644
index 00000000000..85b41ba7b28
--- /dev/null
+++ b/main/postgresql14/fix-test-temp-schema-cleanup.patch
@@ -0,0 +1,14 @@
+A nasty workaround for the faulty test.
+
+Related to https://www.postgresql.org/message-id/20220304.113347.2105652521035137491.horikyota.ntt@gmail.com
+but pg_terminate_backend() accepts the second argument since PostgreSQL 14.
+--- a/src/test/isolation/expected/temp-schema-cleanup.out
++++ b/src/test/isolation/expected/temp-schema-cleanup.out
+@@ -86,7 +86,6 @@
+ SELECT pg_terminate_backend(pg_backend_pid());
+
+ FATAL: terminating connection due to administrator command
+-FATAL: terminating connection due to administrator command
+ server closed the connection unexpectedly
+ This probably means the server terminated abnormally
+ before or while processing the request.