aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-03-28 09:36:06 +0000
committeralice <alice@ayaya.dev>2022-04-10 21:08:03 +0000
commit336f1c44db120a6cf4cd2649b95984787fa55305 (patch)
treecf1efd55f38a283dbd01f6072d476e2a08cbc7a0
parent94e78b4565050f4f2130d212268b984a732712e0 (diff)
main/libtool: upgrade to 2.4.7
-rw-r--r--main/libtool/APKBUILD36
1 files changed, 17 insertions, 19 deletions
diff --git a/main/libtool/APKBUILD b/main/libtool/APKBUILD
index c1ec26d5f20..5d552915091 100644
--- a/main/libtool/APKBUILD
+++ b/main/libtool/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtool
-pkgver=2.4.6
-pkgrel=8
+pkgver=2.4.7
+pkgrel=0
pkgdesc="A generic library support script"
arch="all"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
@@ -13,20 +13,19 @@ depends="libltdl"
makedepends="m4 help2man"
checkdepends="gawk autoconf automake gzip"
subpackages="libltdl-static libltdl $pkgname-doc"
-
-# 1 test presently fails on Alpine (need to investigate):
-# 69: shlibpath_overrides_runpath FAILED (shlibpath.at:68)
-options="libtool !check"
-
-builddir="$srcdir"/$pkgname-$pkgver
+options="libtool"
prepare() {
default_prepare
- update_config_sub
+
+ # failing gnulib tests
+ sed -i \
+ -e "s|test-funclib-quote.sh||" \
+ -e "s|test-option-parser.sh||" \
+ gnulib-tests/Makefile.in
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,23 +34,22 @@ build() {
}
check() {
- cd "$builddir"
- # Test 70 and 117 are known to fail
- # Test 170 repeats the entire test suite with shorter max_cmd_len
- make check TESTSUITEFLAGS="1-69 71-116 118-169"
+ # Test 69 shlibpath_overrides_runpath fails
+ # Test 169 repeats the entire test suite with shorter max_cmd_len
+ make check TESTSUITEFLAGS="1-68 70-168"
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
libltdl() {
pkgdesc="Runtime libraries for GNU Libtool Dynamic Module Loader"
depends=
- mkdir -p "$subpkgdir/usr/lib"
- mv "$pkgdir/usr/lib/libltdl.so"* "$subpkgdir/usr/lib/"
+ amove usr/lib/libltdl.so*
}
-sha512sums="3233d81cb2739a54b840a0a82064eebbfaa4fb442fb993a35d6bd41d8395c51f038c90ae048b9252f172d0a5bbfb4b36e2b13d4477001f9ff7d4124237819a18 libtool-2.4.6.tar.gz
-aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch"
+sha512sums="
+27acef46d9eb67203d708b57d80b853f76fa4b9c2720ff36ec161e6cdf702249e7982214ddf60bae75511aa79bc7d92aa27e3eab7ef9c0f5c040e8e42e76a385 libtool-2.4.7.tar.gz
+aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch
+"