aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-08-29 07:03:11 +0000
committerpsykose <alice@ayaya.dev>2022-08-29 09:03:11 +0200
commit359905d3e8414303f02d80aa833a83b02bf0f074 (patch)
treeb19def61090392c1589f27bff23ba23a9f7aa152
parentc66567eec506dcbe0ead41b2ee28f01470c816c7 (diff)
testing/gzdoom: don't shared link discord lib
so it links into gzdoom instead of needing to be moved
-rw-r--r--testing/gzdoom/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/testing/gzdoom/APKBUILD b/testing/gzdoom/APKBUILD
index 80aab2817df..37dd6000416 100644
--- a/testing/gzdoom/APKBUILD
+++ b/testing/gzdoom/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
pkgname=gzdoom
pkgver=4.8.2
-pkgrel=3
+pkgrel=4
pkgdesc="Feature centric port for all Doom engine games"
url="https://www.zdoom.org/"
# ppc64le blocked by zmusic
@@ -51,18 +51,14 @@ build() {
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_SHARED_LIBS=True \
-DDYN_GTK=OFF \
-DDYN_OPENAL=OFF \
- -DNO_OPENMP=OFF \
$CMAKE_CROSSOPTS
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
- install -Dm755 build/libraries/discordrpc/src/libdiscord-rpc.so \
- -t "$pkgdir"/usr/lib/
}
sha512sums="