aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-05-20 00:19:02 +0000
committerpsykose <alice@ayaya.dev>2023-05-20 02:19:03 +0200
commit3607d4633d9710f355d96d950e4dfda83380e41f (patch)
tree8c695e36c16155a9a7edef12c0ff8530819902dd
parent5bf4cfc43da6c2bf3e22feaa233efaa86aee582c (diff)
testing/gamescope: fix gcc13 build
-rw-r--r--testing/gamescope/APKBUILD4
-rw-r--r--testing/gamescope/gcc13.patch41
2 files changed, 44 insertions, 1 deletions
diff --git a/testing/gamescope/APKBUILD b/testing/gamescope/APKBUILD
index b08d0d35bb2..1e702617bad 100644
--- a/testing/gamescope/APKBUILD
+++ b/testing/gamescope/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Alisa <corg@disroot.org>
pkgname=gamescope
pkgver=3.11.51
-pkgrel=5
+pkgrel=6
_vkroots=e6b89494142eec0ac6061f82a947d2f1246d3d7a
pkgdesc="SteamOS session compositing window manager"
url="https://github.com/Plagman/gamescope"
@@ -31,6 +31,7 @@ makedepends="
"
source="https://github.com/Plagman/gamescope/archive/refs/tags/$pkgver/gamescope-$pkgver.tar.gz
vkroots-$_vkroots.tar.gz::https://github.com/Joshua-Ashton/vkroots/archive/$_vkroots.tar.gz
+ gcc13.patch
system-wlroots-libliftoff.patch
libliftoff-0.4.patch
"
@@ -57,6 +58,7 @@ package() {
sha512sums="
a4ddd96a4fdacd62eee800f6fb331d08fca32c2798d64148529181a0ee8d8af57d5d67bfa28bff8e9cf62047a7572c43b36e2968660ea2984b8e21fa812baf9e gamescope-3.11.51.tar.gz
a1a21f53d38385a5f300d9dd5650145074baad66b081beaab59179995afcc5a8df8adf19d52c5da15a7ee10fa530aa9d24c3ff1e04df3f7e1d3af526abc1e55e vkroots-e6b89494142eec0ac6061f82a947d2f1246d3d7a.tar.gz
+83ba06fbf89d84d1e56a69c5feb474ab3d1f2b2ccf686d5bdd4c408065b7aaaf0a847979e8e5e8d815d02b5fc88ce4592f88af7f2b2eaf9668b9cdad0070f17d gcc13.patch
9fea6675d8c29d740c77d9ce6b69da4a1f54f39bf7a372fe538f154bb97f5cc21436033eeab1f2a154c5aee04410e5194b779c33104ab78b1a8a84ca5d798be2 system-wlroots-libliftoff.patch
586b9d9704e6ec5a7bd0eccc46c406bd6bcc547c96b8089e43c655e36adc0dc0d8c8270da37cef9de6f2ea8f0c5461e9882a12d261b38dc93e8b52947af87980 libliftoff-0.4.patch
"
diff --git a/testing/gamescope/gcc13.patch b/testing/gamescope/gcc13.patch
new file mode 100644
index 00000000000..6b0b47c94c1
--- /dev/null
+++ b/testing/gamescope/gcc13.patch
@@ -0,0 +1,41 @@
+diff --git a/src/drm.hpp b/src/drm.hpp
+index 2f416c4..849ec96 100644
+--- a/src/drm.hpp
++++ b/src/drm.hpp
+@@ -40,12 +40,13 @@ extern "C" {
+
+ #include "rendervulkan.hpp"
+
++#include <string>
+ #include <unordered_map>
+ #include <utility>
+ #include <atomic>
+ #include <map>
+ #include <unordered_map>
+ #include <mutex>
+ #include <vector>
+
+ struct saved_mode {
+diff --git a/src/main.cpp b/src/main.cpp
+index 99a7a48..4cab9d1 100644
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -2,6 +2,7 @@
+
+ #include <cstdio>
+ #include <thread>
++#include <string>
+ #include <mutex>
+ #include <vector>
+ #include <cstring>
+diff --git a/src/sdlwindow.cpp b/src/sdlwindow.cpp
+index ecf95ce..d886e15 100644
+--- a/src/sdlwindow.cpp
++++ b/src/sdlwindow.cpp
+@@ -1,5 +1,6 @@
+ // For the nested case, reads input from the SDL window and send to wayland
+
++#include <string>
+ #include <thread>
+ #include <mutex>
+