aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-08-01 13:36:42 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-01 14:34:01 +0000
commit362d7768af8088d272beb369284f144a01cf9ba6 (patch)
treec98982f78523d23d33526dedb616edf929fdc57e
parent8fe1b65a49b4942037671dd9ed56599a67b31c70 (diff)
community/konversation: fix build against Qt 5.15
-rw-r--r--community/konversation/0001-qt-5.15.patch31
-rw-r--r--community/konversation/0002-unused-kemoticons.patch112
-rw-r--r--community/konversation/0003-missing-header.patch (renamed from community/konversation/0001-Fix-build-with-Qt-5.13.patch)6
-rw-r--r--community/konversation/APKBUILD44
4 files changed, 182 insertions, 11 deletions
diff --git a/community/konversation/0001-qt-5.15.patch b/community/konversation/0001-qt-5.15.patch
new file mode 100644
index 00000000000..a17c0a43231
--- /dev/null
+++ b/community/konversation/0001-qt-5.15.patch
@@ -0,0 +1,31 @@
+From f88c73cf278da9907496eab0777903f942c50cb9 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 21 Apr 2020 10:34:49 +0200
+Subject: [PATCH] Fix build with Qt 5.15 (missing header)
+
+Test Plan: Build succeeds with Qt 5.15.0_beta4
+
+Reviewers: #konversation, psn
+
+Reviewed By: #konversation, psn
+
+Differential Revision: https://phabricator.kde.org/D29038
+---
+ src/viewer/viewtree.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/viewer/viewtree.cpp b/src/viewer/viewtree.cpp
+index eeee8fb4..04ec4e54 100644
+--- a/src/viewer/viewtree.cpp
++++ b/src/viewer/viewtree.cpp
+@@ -21,6 +21,7 @@
+ #include <QFontDatabase>
+ #include <QGuiApplication>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QItemSelectionModel>
+ #include <QStyleHints>
+ #include <QToolTip>
+--
+2.26.1
+
diff --git a/community/konversation/0002-unused-kemoticons.patch b/community/konversation/0002-unused-kemoticons.patch
new file mode 100644
index 00000000000..d856a17215a
--- /dev/null
+++ b/community/konversation/0002-unused-kemoticons.patch
@@ -0,0 +1,112 @@
+From 271da4bd1e584026fc24d93474ca6cf9e50fa6d7 Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Mon, 16 Sep 2019 18:18:49 +0100
+Subject: Drop effectively unused kemoticons support
+
+Summary:
+Konversation only supported emoticons if config value EnableEmotIcons
+was true. This by default was false and there is no UI for configuring
+this, making it effectively unused.
+
+This appears to be deliberate from the code comments.
+
+This helps clear up some KEmoticon library usage for future KF6
+transitioning.
+
+UTF-8 emoticons work correctly.
+
+Test Plan: Compiles
+
+Differential Revision: https://phabricator.kde.org/D24000
+---
+ src/CMakeLists.txt | 2 --
+ src/config/konversation.kcfg | 8 --------
+ src/viewer/ircview.cpp | 3 ---
+ 3 files changed, 13 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index c2077b3..89616a6 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -138,7 +138,6 @@ set(viewer_SRCS
+ viewer/topiclabel.cpp
+ viewer/awaylabel.cpp
+ viewer/editnotifydialog.cpp
+- viewer/emoticons.cpp
+ viewer/images.cpp
+ viewer/quickbutton.cpp
+ viewer/searchbar.cpp
+@@ -224,7 +223,6 @@ target_link_libraries(konversation
+ KF5::Bookmarks
+ KF5::ConfigWidgets
+ KF5::Crash
+- KF5::Emoticons
+ KF5::I18n
+ KF5::IdleTime
+ KF5::NotifyConfig
+diff --git a/src/config/konversation.kcfg b/src/config/konversation.kcfg
+index 1d59eaf..3f0b7a6 100644
+--- a/src/config/konversation.kcfg
++++ b/src/config/konversation.kcfg
+@@ -844,14 +844,6 @@
+ <label></label>
+ <whatsthis></whatsthis>
+ </entry>
+- <entry key="EnableEmotIcons" type="Bool">
+- <default>false</default>
+- <label>Enable emoticons</label>
+- </entry>
+- <entry key="EmotIconTheme" type="String">
+- <default>Default</default>
+- <label>Emoticons theme</label>
+- </entry>
+ </group>
+ <group name="PreferencesDialog">
+ <entry name="PreferencesDialogSize" key="Size" type="Size">
+diff --git a/src/viewer/ircview.cpp b/src/viewer/ircview.cpp
+index c129f61..15f78ca 100644
+--- a/src/viewer/ircview.cpp
++++ b/src/viewer/ircview.cpp
+@@ -20,7 +20,6 @@
+ #include "application.h"
+ #include "highlight.h"
+ #include "sound.h"
+-#include "emoticons.h"
+ #include "notificationhandler.h"
+
+ #include <QDrag>
+@@ -1214,8 +1213,6 @@ QString IRCView::filter(const QString& line, const QString& defaultColor, const
+ QLatin1String("\">") + filteredLine + QLatin1String("</font>");
+ }
+
+- filteredLine = Konversation::Emoticons::parseEmoticons(filteredLine);
+-
+ return filteredLine;
+ }
+
+--
+cgit v1.1
+
+From f1e6ec37b9a9ead194606795ed23a1ec70a784cc Mon Sep 17 00:00:00 2001
+From: Peter Simonsson <peter.simonsson@gmail.com>
+Date: Tue, 7 Apr 2020 16:37:53 +0200
+Subject: Remove KEmoticons from dependencies as it's not used
+
+---
+ CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5315dbd..19facd8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -24,7 +24,6 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
+ CoreAddons
+ Crash
+ DocTools
+- Emoticons
+ I18n
+ IdleTime
+ NotifyConfig
+--
+cgit v1.1
diff --git a/community/konversation/0001-Fix-build-with-Qt-5.13.patch b/community/konversation/0003-missing-header.patch
index f92dd340584..1ff14b81ec5 100644
--- a/community/konversation/0001-Fix-build-with-Qt-5.13.patch
+++ b/community/konversation/0003-missing-header.patch
@@ -1,14 +1,14 @@
From 4d0036617becc26a76fd021138c98aceec4c7b53 Mon Sep 17 00:00:00 2001
From: Luca Beltrame <lbeltrame@kde.org>
Date: Sun, 21 Jul 2019 09:14:32 +0200
-Subject: [PATCH] Fix build with Qt 5.13
+Subject: Fix build with Qt 5.13
---
src/irc/outputfilter.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/irc/outputfilter.cpp b/src/irc/outputfilter.cpp
-index f9e6253f..45d11fb2 100644
+index f9e6253..45d11fb 100644
--- a/src/irc/outputfilter.cpp
+++ b/src/irc/outputfilter.cpp
@@ -32,6 +32,7 @@
@@ -19,3 +19,5 @@ index f9e6253f..45d11fb2 100644
#include <QRegExp>
#include <QTextCodec>
#include <QByteArray>
+--
+cgit v1.1
diff --git a/community/konversation/APKBUILD b/community/konversation/APKBUILD
index 3872728e0da..637fbf500e3 100644
--- a/community/konversation/APKBUILD
+++ b/community/konversation/APKBUILD
@@ -2,19 +2,43 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=konversation
pkgver=1.7.5
-pkgrel=1
+pkgrel=2
arch="all !armhf"
url="https://konversation.kde.org/"
pkgdesc="A user-friendly and fully-featured IRC client"
license="GPL-2.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev karchive-dev kbookmarks-dev
- kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev kdoctools-dev
- kemoticons-dev ki18n-dev kidletime-dev knotifyconfig-dev kio-dev
- kparts-dev solid-dev kwallet-dev kwidgetsaddons-dev kglobalaccel-dev
- kdbusaddons-dev knotifications-dev kwindowsystem-dev kiconthemes-dev
- kitemviews-dev phonon-dev qca-dev"
+makedepends="
+ extra-cmake-modules
+ karchive-dev
+ kbookmarks-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kglobalaccel-dev
+ ki18n-dev
+ kiconthemes-dev
+ kidletime-dev
+ kio-dev
+ kitemviews-dev
+ knotifications-dev
+ knotifyconfig-dev
+ kparts-dev
+ kwallet-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ phonon-dev
+ qca-dev
+ qt5-qtbase-dev
+ solid-dev
+ "
source="https://download.kde.org/stable/konversation/$pkgver/src/konversation-$pkgver.tar.xz
- 0001-Fix-build-with-Qt-5.13.patch"
+ 0001-qt-5.15.patch
+ 0002-unused-kemoticons.patch
+ 0003-missing-header.patch
+ "
subpackages="$pkgname-doc $pkgname-lang"
build() {
@@ -35,4 +59,6 @@ package() {
}
sha512sums="001534c7f6c5110ca5e210977cc4275e083f5c3704078a74aa573af659154e0fa4c3c960be08f41256db1ac4568f0734741bf10cfb2e15d9e6f6440250682504 konversation-1.7.5.tar.xz
-20e7626721286194ee036d64bdb5faae1b774bc19a3958f221c03e3269b0d4ce6e768d6e4ee7c2db1ec9502ac2be202184cb842d072f321422664d62f56212ec 0001-Fix-build-with-Qt-5.13.patch"
+056a3d6c17b04734e446b623b88dfa9fd4a90133c251b427460f5c6f3f85a52ad46abe92b055e8a5eb86f433f67e4645f9999d6124d3343466b741d99c11b076 0001-qt-5.15.patch
+3158d47aad3920715bd9dc010585e4a2e7488872a24cac8f69bff8ebafc4445d54611756ad05399d8bbd1b4be37fb28d8566577fbc040559fdad3ab18927e3df 0002-unused-kemoticons.patch
+b9b1b2e4b231d2a4beb63a6e757467ec0d32bfc9005dd990d7649cc6ac9c34d106b0b15bc3918490ef4ded81699e5d84161b3a1d8541aa6232ba485124b65386 0003-missing-header.patch"