aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-04-30 22:00:23 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-04-30 22:03:30 +0000
commit3637cad9b798191474dd582fe00ca8ad317e237e (patch)
treea764142865229117a1ed22a79dc621e352cee953
parent8620b15df4554a00d09581ad40a52297cd8869f7 (diff)
community/py3-aiohttp-cors-gns3: new aport
This has been introduced due to a long required compatibility for GNS3. In alpine we are upgrading to the latest version (which often breaks ABI), while GNS3 sticks to older versions. This new aport introduce a layer of compatibility, following what also Archlinux does. It is pushed in community directly in order to be a dependency of GNS3, though has been tested.
-rw-r--r--community/py3-aiohttp-cors-gns3/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-aiohttp-cors-gns3/APKBUILD b/community/py3-aiohttp-cors-gns3/APKBUILD
new file mode 100644
index 00000000000..83b030071fc
--- /dev/null
+++ b/community/py3-aiohttp-cors-gns3/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-aiohttp-cors-gns3
+_pkgname=aiohttp_cors
+pkgver=0.5.3
+pkgrel=0
+pkgdesc="CORS support for aiohttp - GNS3 compatible version"
+url="https://github.com/aio-libs/aiohttp-cors"
+arch="noarch"
+license="Apache-2.0"
+depends="py3-aiohttp-gns3"
+conflict="py3-aiohttp-cors"
+makedepends="python3-dev py3-setuptools"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/aio-libs/aiohttp-cors/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/aiohttp-cors-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0813ea48de714c85e361dfdaeef1a69526f7446dcc4ce637139cd333dedea58c635f85cfad1c3ccfb0df6e573f0351f282fdbd9726211d5915ed2ba120206b09 aiohttp_cors-0.5.3.tar.gz"