aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2013-10-03 14:11:26 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2013-10-03 14:11:26 +0000
commit36c22946e4045d372ebe17281b2a0f17d4b2f22e (patch)
tree17ab579e1683d2b000d0f87ab5b620047d63caef
parentc81d99f27cea21e91801f18a32e9b44bb8c9e295 (diff)
testing/apache2-mod-perl: upgrade tp 2.0.8
-rw-r--r--testing/apache2-mod-perl/APKBUILD26
-rw-r--r--testing/apache2-mod-perl/mod_perl-2.0.6-nolfs.patch13
-rw-r--r--testing/apache2-mod-perl/mod_perl-remote-ip.patch70
3 files changed, 103 insertions, 6 deletions
diff --git a/testing/apache2-mod-perl/APKBUILD b/testing/apache2-mod-perl/APKBUILD
index f0fa8626ae1..9f6100c9388 100644
--- a/testing/apache2-mod-perl/APKBUILD
+++ b/testing/apache2-mod-perl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=apache2-mod-perl
_realname=mod_perl
-pkgver=2.0.7
+pkgver=2.0.8
pkgrel=0
pkgdesc="Perl Module for Apache2"
url="http://perl.apache.org/"
@@ -10,12 +10,13 @@ arch="all"
license="APACHE"
depends="apache2 perl"
depends_dev=
-makedepends="$depends_dev apache2-dev perl-dev"
+makedepends="$depends_dev apache2-dev perl-dev perl-linux-pid apr-dev"
install="$pkgname.post-install"
subpackages="$pkgname-doc $pkgname-dev"
source="http://search.cpan.org/CPAN/authors/id/P/PH/PHRED/${_realname}-${pkgver}.tar.gz
$pkgname.apache2.conf
- mod_perl-2.0.5-nolfs.patch
+ mod_perl-2.0.6-nolfs.patch
+ mod_perl-remote-ip.patch
"
_builddir="$srcdir"/${_realname}-${pkgver}
@@ -30,8 +31,12 @@ prepare() {
build() {
cd "$_builddir"
+ make source_scan
+ make xs_generate
+
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor \
- MP_APXS=/usr/sbin/apxs || return 1
+ MP_APXS=/usr/bin/apxs \
+ MP_APR_CONFIG=/usr/bin/apr-1-config || return 1
make || return 1
}
@@ -64,6 +69,15 @@ doc() {
|| return 1
}
-md5sums="e8b3d7b6d67505a8e3050cb9042b944b mod_perl-2.0.7.tar.gz
+md5sums="df89f50a39e93ba5054651c281483ffb mod_perl-2.0.8.tar.gz
86b84bb56b49a95772a7f773fc019043 apache2-mod-perl.apache2.conf
-088e082afef57f92f234a01269e24ce5 mod_perl-2.0.5-nolfs.patch"
+d80a159888ee934de9e959c1926423ff mod_perl-2.0.6-nolfs.patch
+6a68139aeb26a690d1a2c0a8e12e60c2 mod_perl-remote-ip.patch"
+sha256sums="35dc1b7a40a90a395ce88bba2df84f22289975f34d1757de6d715560c20a20e6 mod_perl-2.0.8.tar.gz
+92dfc84c1506f34fc55cb65f4f2b0399254d811a03c5bcea1e6cf010e60a5227 apache2-mod-perl.apache2.conf
+5d1b6a051d847108b23b5dc06ea5885c37dd81d3a9156b69d179d95b5cf92f08 mod_perl-2.0.6-nolfs.patch
+c2c0b24f0a700c77fd89018681689a752eab8d06068bb285bbe38b6a34ddfcdd mod_perl-remote-ip.patch"
+sha512sums="d5090651699c4436fe8d0a525226543c971aa05db337dc1b1e89023183df1c7dd8b8775f3a0f7d3b9ec40e8c058ac23bd24141cf15a5fe5806226d634dfb4c87 mod_perl-2.0.8.tar.gz
+716650058af077b0494833301f3dfdf517499bdb2021427431cacc7f63e5fe520cd6f5f7daee44bed15e257c9a2d1fb7d18a75954455fa894dd24a8ef32af50b apache2-mod-perl.apache2.conf
+75515c3bdb70b25756bba81f9b2c643b34b80bfc3e0e449971d8b6a3860639767b7393002ab3793a9dc8d37855a2aafbeabc2a8e957a5834f480ccc38bb605ba mod_perl-2.0.6-nolfs.patch
+80bc16d4c17387ddb6e4106b7b7eeb572cfbd86f88313026c18a2f08646cc6ca916b2f275a126ec52e4e8fb393d31d1db737ddd4aa2e1b34573b1991979d0660 mod_perl-remote-ip.patch"
diff --git a/testing/apache2-mod-perl/mod_perl-2.0.6-nolfs.patch b/testing/apache2-mod-perl/mod_perl-2.0.6-nolfs.patch
new file mode 100644
index 00000000000..13e5ccceedf
--- /dev/null
+++ b/testing/apache2-mod-perl/mod_perl-2.0.6-nolfs.patch
@@ -0,0 +1,13 @@
+diff -upr mod_perl-2.0.6.orig/lib/Apache2/Build.pm mod_perl-2.0.6/lib/Apache2/Build.pm
+--- mod_perl-2.0.6.orig/lib/Apache2/Build.pm 2012-05-26 22:31:00.000000000 +0300
++++ mod_perl-2.0.6/lib/Apache2/Build.pm 2012-05-26 22:31:32.000000000 +0300
+@@ -2207,7 +2207,8 @@ sub has_large_files_conflict {
+ # with it is that we didn't have such a case yet, but may need to
+ # deal with it later
+
+- return $perl_lfs64 ^ $apr_lfs64;
++ return 0;
++ # $perl_lfs64 ^ $apr_lfs64;
+ }
+
+ # if perl is built with uselargefiles, but apr not, the build won't
diff --git a/testing/apache2-mod-perl/mod_perl-remote-ip.patch b/testing/apache2-mod-perl/mod_perl-remote-ip.patch
new file mode 100644
index 00000000000..e39d629d2ea
--- /dev/null
+++ b/testing/apache2-mod-perl/mod_perl-remote-ip.patch
@@ -0,0 +1,70 @@
+Index: xs/tables/current/Apache2/StructureTable.pm
+===================================================================
+--- a/xs/tables/current/Apache2/StructureTable.pm (revision 1324590)
++++ b/xs/tables/current/Apache2/StructureTable.pm (working copy)
+@@ -2708,11 +2708,11 @@
+ },
+ {
+ 'type' => 'apr_sockaddr_t *',
+- 'name' => 'remote_addr'
++ 'name' => 'client_addr'
+ },
+ {
+ 'type' => 'char *',
+- 'name' => 'remote_ip'
++ 'name' => 'client_ip'
+ },
+ {
+ 'type' => 'char *',
+@@ -2955,6 +2955,14 @@
+ },
+ {
+ 'type' => 'char *',
++ 'name' => 'useragent_ip'
++ },
++ {
++ 'type' => 'apr_sockaddr_t *',
++ 'name' => 'useragent_addr'
++ },
++ {
++ 'type' => 'char *',
+ 'name' => 'the_request'
+ },
+ {
+@@ -3245,10 +3253,6 @@
+ },
+ {
+ 'type' => 'int',
+- 'name' => 'loglevel'
+- },
+- {
+- 'type' => 'int',
+ 'name' => 'is_virtual'
+ },
+ {
+Index: Apache-Reload/Makefile.PL
+===================================================================
+--- a/Apache-Reload/Makefile.PL (revision 1324590)
++++ b/Apache-Reload/Makefile.PL (working copy)
+@@ -11,7 +11,7 @@
+ # MOD_PERL_2_BUILD is set from building from mod_perl Makefile.PL which should
+ # also set MP_APXS
+ if ($ENV{MOD_PERL_2_BUILD}) {
+- push @ARGV, "-apxs", $ENV{MP_APXS};
++ push @ARGV, "-apxs $ENV{MP_APXS}";
+ my $mp_gen = satisfy_mp_generation(2);
+ }
+ else {
+Index: Apache-SizeLimit/Makefile.PL
+===================================================================
+--- a/Apache-SizeLimit/Makefile.PL (revision 1324590)
++++ b/Apache-SizeLimit/Makefile.PL (working copy)
+@@ -11,7 +11,7 @@
+ # MOD_PERL_2_BUILD is set from building from mod_perl Makefile.PL which should
+ # also set MP_APXS
+ if ($ENV{MOD_PERL_2_BUILD}) {
+- push @ARGV, "-apxs", $ENV{MP_APXS};
++ push @ARGV, "-apxs $ENV{MP_APXS}";
+ my $mp_gen = satisfy_mp_generation(2);
+ }
+ else {