aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-12-15 21:32:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-12-17 18:31:07 +0000
commit394299204cfbc7f4b6495cf1cf99811e082ba857 (patch)
tree1737fe5524b0465e15f2a2afc40edc17eaab71f8
parent50b44668d26f6c0943ae548926b220a729f470f9 (diff)
community/frr: upgrade to 7.5
-rw-r--r--community/frr/APKBUILD10
-rw-r--r--community/frr/allow-invalid-nlri-attributes.patch4
2 files changed, 7 insertions, 7 deletions
diff --git a/community/frr/APKBUILD b/community/frr/APKBUILD
index 9dc14fe37a6..d29c6571cd4 100644
--- a/community/frr/APKBUILD
+++ b/community/frr/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Daniel Corbe <daniel@corbe.net>
pkgname=frr
-pkgver=7.4
-pkgrel=2
+pkgver=7.5
+pkgrel=0
pkgdesc="Free Range Routing is a fork of Quagga"
pkgusers="frr"
pkggroups="frr frrvty"
url="https://frrouting.org/"
-arch="all !s390x" # failing tests
+arch="all"
license="GPL-2.0-or-later"
depends="iproute2 bash libcap"
makedepends="autoconf automake libtool
@@ -125,6 +125,6 @@ snmp() {
mv "$pkgdir"/usr/lib/frr/libfrrsnmp.* "$subpkgdir/usr/lib/frr"
}
-sha512sums="d5c4e3bf7527bc094a65b24fda1b7a86f87e996fb3d98abe646e878274e0ca30f45aefca76816414b9d44607616cd2eb8ad118045b8986a92dd130f3a704162f frr-7.4.tar.gz
+sha512sums="d0d3c0bc0d30e2ebb93e20906768a996d21db23b23118c8e3c50d238e7bfdee7a789b4a90c9d7dbdc842d857f60bd44f0922b01b0c2c8b289ac860f008a430a9 frr-7.5.tar.gz
b495b2be9f2cbb065104ccc0c3474471e870b53ac62ed4fba40020c8d50866e637a99ef3d7af5de1018ff659c4757baac4f40d7648a9de99ed14db33c8992b54 frr.initd
-5a41a4daf479aa24c424565728cf1bd175c993704ddc7527f11c466dd89fef409069e772cee87cdd9f30903d7a3ee33b1b662c3948ae4bbac126313e6a83ff8f allow-invalid-nlri-attributes.patch"
+8c4e498d9a0496d23e2a95a1004e062f6838007a1c0eb52d7873e675c5587b69b51cbff73202e38231221d164c75f7a1e25b0621b20c78a5e7635aaa0c586053 allow-invalid-nlri-attributes.patch"
diff --git a/community/frr/allow-invalid-nlri-attributes.patch b/community/frr/allow-invalid-nlri-attributes.patch
index 07bceb7ceb2..1eb913be479 100644
--- a/community/frr/allow-invalid-nlri-attributes.patch
+++ b/community/frr/allow-invalid-nlri-attributes.patch
@@ -4,7 +4,7 @@ Upstream: Not at the moment
diff -urN frr-frr-7.4.orig/bgpd/bgp_attr.c frr-frr-7.4/bgpd/bgp_attr.c
--- frr-frr-7.4.orig/bgpd/bgp_attr.c 2020-10-08 18:05:11.115803185 -0600
+++ frr-frr-7.4/bgpd/bgp_attr.c 2020-10-08 18:06:18.132718181 -0600
-@@ -2169,9 +2169,13 @@
+@@ -2199,9 +2199,13 @@
*/
if (length == 0) {
attr->lcommunity = NULL;
@@ -18,7 +18,7 @@ diff -urN frr-frr-7.4.orig/bgpd/bgp_attr.c frr-frr-7.4/bgpd/bgp_attr.c
}
attr->lcommunity = lcommunity_parse(stream_pnt(peer->curr), length);
-@@ -2179,8 +2183,12 @@
+@@ -2213,8 +2213,12 @@
stream_forward_getp(peer->curr, length);
if (!attr->lcommunity)