aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-04-18 21:02:25 +0000
committerpsykose <alice@ayaya.dev>2023-04-18 23:02:25 +0200
commit39d12a148d027849ce1b2d24c06b8d13830cd5ef (patch)
treecfee30b7b1a4fee4377c221930126fda24bbf9c3
parentb1613ef009f12beb8de05abe1668753e9ea37376 (diff)
community/influxdb: remove
the packaged version was released 2 years ago- since then, the project has had numerous releases, but nobody has maintained it and updated it. the reason for that is mostly that it is almost unbuildable and the new build system is quite unworkable.
-rw-r--r--community/influxdb/APKBUILD73
-rw-r--r--community/influxdb/influxdb.confd4
-rw-r--r--community/influxdb/influxdb.initd16
-rw-r--r--community/influxdb/influxdb.pre-install8
4 files changed, 0 insertions, 101 deletions
diff --git a/community/influxdb/APKBUILD b/community/influxdb/APKBUILD
deleted file mode 100644
index bafa92687f4..00000000000
--- a/community/influxdb/APKBUILD
+++ /dev/null
@@ -1,73 +0,0 @@
-# Contributor: Stefan Wagner <stw@bit-strickerei.de>
-# Maintainer:
-pkgname=influxdb
-pkgver=1.8.10
-pkgrel=13
-_commit=688e697c51 # git rev-parse --short HEAD
-_branch=${pkgver%.*}
-pkgdesc="Scalable datastore for metrics, events, and real-time analytics"
-url="https://www.influxdata.com/products/influxdb-overview/"
-# riscv64 blocked by boltdb dependency
-arch="all !riscv64"
-license="MIT"
-makedepends="go asciidoc xmlto"
-install="$pkgname.pre-install"
-subpackages="$pkgname-doc $pkgname-openrc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/influxdata/influxdb/archive/v$pkgver.tar.gz
- influxdb.initd influxdb.confd"
-# multiple tests don't build due to very simple go errors
-options="chmod-clean net !check"
-
-export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
-export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
-export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
-
-build() {
- local ldflags="-X main.version=$pkgver -X main.branch=$_branch -X main.commit=$_commit"
- local pkgs="influx influx_inspect influx_stress influx_tools influxd"
- local pkg
- for pkg in $pkgs; do
- go build -ldflags "$ldflags" -o ./bin/$pkg ./cmd/$pkg
- done
- make -C man
-}
-
-check() {
- local pkgs="./..."
- case "$CARCH" in
- # One test in query pkg fail because of lesser float number precision, should be safe to ignore.
- s390x | aarch64 | ppc64le) pkgs="$(go list ./... | grep -Ev '(^github.com/influxdata/influxdb/query$)|(^github.com/influxdata/influxdb/client$)|(^github.com/influxdata/influxdb/tsdb/index/inmem$)')" ;;
- # client pkg - error message changed in go1.14, not important here.
- # tsdb/index/inmem - bug in test.
- *) pkgs="$(go list ./... | grep -Ev '(^github.com/influxdata/influxdb/tsdb/index/inmem$)|(^github.com/influxdata/influxdb/client$)')" ;;
- esac
-
- # CI too slow, some tests timeout.
- [ "$CARCH" == "armv7" ] && return 0
-
- ulimit -n 4096 # Checks fail on aarch64 with: 'too many open files'
- go test -short $pkgs
-}
-
-package() {
- local pkgs="influx influx_inspect influx_stress influx_tools"
- local pkg
- for pkg in $pkgs; do
- install -Dm755 "$builddir/bin/$pkg" "$pkgdir/usr/bin/$pkg"
- done
- install -Dm755 "$builddir/bin/influxd" "$pkgdir/usr/sbin/influxd"
-
- install -d "$pkgdir/usr/share/man/man1/"
- install -Dm644 man/*.1 "$pkgdir/usr/share/man/man1/"
-
- install -Dm644 "etc/config.sample.toml" "$pkgdir/etc/influxdb.conf"
-
- install -Dm755 "$srcdir/$pkgname.initd" "$pkgdir/etc/init.d/$pkgname"
- install -Dm644 "$srcdir/$pkgname.confd" "$pkgdir/etc/conf.d/$pkgname"
-}
-
-sha512sums="
-4f5d20c190288d6397f0e87abd9b9136340b17f091c361cbc111ba661a3e63626edf5c74ddeeda164d82102dd06026e0037f50da546cda25e6c8647f4c739fae influxdb-1.8.10.tar.gz
-bc850c5a53510801435ee700a80d204a084d773b94bbb6f3aa39744d3a88f3b189596dc8d4c618c4d9c97cb8d26ec50608bfaa6a78550c5b86c146c96e744460 influxdb.initd
-1db8790c84a9e193a6029291b2a83a6083d1ddcc330c2191c4da6bdcc6410d832288aee275605b4ca041c8855fe8a1340631444e901044659755db0146d6d3dc influxdb.confd
-"
diff --git a/community/influxdb/influxdb.confd b/community/influxdb/influxdb.confd
deleted file mode 100644
index e30920fa74e..00000000000
--- a/community/influxdb/influxdb.confd
+++ /dev/null
@@ -1,4 +0,0 @@
-INFLUXDB_OPTS="-config /etc/influxdb.conf"
-
-# Uncomment to enable logging to syslog.
-#error_logger="logger -t $RC_SVCNAME"
diff --git a/community/influxdb/influxdb.initd b/community/influxdb/influxdb.initd
deleted file mode 100644
index 15db4e0c544..00000000000
--- a/community/influxdb/influxdb.initd
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/sbin/openrc-run
-
-pidfile=/run/$RC_SVCNAME.pid
-command=/usr/sbin/influxd
-command_args="${INFLUXDB_OPTS}"
-command_background="yes"
-command_user="${command_user:-influxdb:influxdb}"
-
-depend() {
- need net
- after firewall
-}
-
-start_pre() {
- checkpath -d -o "$command_user" -m755 "${data_path:-/var/lib/influxdb}"
-}
diff --git a/community/influxdb/influxdb.pre-install b/community/influxdb/influxdb.pre-install
deleted file mode 100644
index fdb2955f161..00000000000
--- a/community/influxdb/influxdb.pre-install
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-name=influxdb
-
-addgroup -S "$name" 2>/dev/null
-adduser -S -D -H -h "/var/lib/$name" -s /sbin/nologin -G "$name" -g "$name" "$name" 2>/dev/null
-
-exit 0