aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-03-16 19:34:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-03-16 19:34:37 +0000
commit3a985146ed7267e032ca94539c0a2b48301dbf05 (patch)
treed609276c31882627a344f8bb6c9b0d8d58bb45bf
parent9eb6048cc7ce4590af96a14594798d8762ee7c6e (diff)
testing/openwsman: fix default config to not use pam
-rw-r--r--testing/openwsman/APKBUILD8
-rw-r--r--testing/openwsman/default-config.patch32
2 files changed, 37 insertions, 3 deletions
diff --git a/testing/openwsman/APKBUILD b/testing/openwsman/APKBUILD
index eb2802267a6..b97ebe1686c 100644
--- a/testing/openwsman/APKBUILD
+++ b/testing/openwsman/APKBUILD
@@ -8,10 +8,11 @@ url="https://openwsman.github.io"
arch="all"
license="custom BSD-3-Clause"
options="!check" # No test suite
-makedepends="cmake openssl-dev perl-dev curl-dev python3-dev sblim-sfcc-dev libxml2-dev"
+makedepends="cmake swig openssl-dev perl-dev curl-dev python3-dev sblim-sfcc-dev libxml2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="$pkgname-$pkgver.tar.gz::https://github.com/Openwsman/$pkgname/archive/v$pkgver.tar.gz
- fix-musl-build.patch"
+ fix-musl-build.patch
+ default-config.patch"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -62,4 +63,5 @@ package() {
}
sha512sums="eb09ff0a988e42b618f022e20fbda5572c548501ed24d9f8eba84e49713153431082a93cd68f55395f9823e56d93d623f39c244c9c936cb0a39bdf138b53635c openwsman-2.6.9.tar.gz
-d031a3fd5f30b71ef87d7fd9c241baf55c20953c175ab0eb6192f9971b7b8a3a9c18693fa2cd468ed7f7ef94170281b7db5e987ba1b88c92d64231e560e91542 fix-musl-build.patch"
+d031a3fd5f30b71ef87d7fd9c241baf55c20953c175ab0eb6192f9971b7b8a3a9c18693fa2cd468ed7f7ef94170281b7db5e987ba1b88c92d64231e560e91542 fix-musl-build.patch
+3c10cb34a0bb0d70461225c0944c0fdaf9aadba2c78ee8122dcf8b493190bc86db0252cc74a7fdb178a2d0a0c26fb3323a1cd8dce320fe21eb0ad2860e42a0f1 default-config.patch"
diff --git a/testing/openwsman/default-config.patch b/testing/openwsman/default-config.patch
new file mode 100644
index 00000000000..70a5e0eff31
--- /dev/null
+++ b/testing/openwsman/default-config.patch
@@ -0,0 +1,32 @@
+diff --git a/etc/openwsman.conf b/etc/openwsman.conf
+index 84326f2..0d701c3 100644
+--- a/etc/openwsman.conf
++++ b/etc/openwsman.conf
+@@ -44,7 +44,7 @@ ssl_disabled_protocols = SSLv2 SSLv3
+ #ssl_cipher_list =
+
+ # set these to enable digest authentication against a local datbase
+-#digest_password_file = /etc/openwsman/digest_auth.passwd
++digest_password_file = /etc/openwsman/digest_auth.passwd
+
+ # set these to enable basic authentication against a local datbase
+ #basic_password_file = /etc/openwsman/simple_auth.passwd
+@@ -59,7 +59,8 @@ max_connections_per_thread = 20
+ # Authentication backend for BASIC authentication. Default is to read a configuration file defined with 'basic_password_file'
+ #
+
+-basic_authenticator = libwsman_pam_auth.so
++#By default, Alpine does not ship pam
++#basic_authenticator = libwsman_pam_auth.so
+ basic_authenticator_arg = openwsman
+
+ #
+@@ -76,7 +77,7 @@ basic_authenticator_arg = openwsman
+ # Location of plugins
+ # defaults to /usr/lib(64)/openwsman/plugins
+ #
+-# plugin_dir = /usr/lib/openwsman/plugins
++plugin_dir = /usr/lib/openwsman/plugins
+
+
+ ##################################