aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-06-05 01:26:22 +0000
committerpsykose <alice@ayaya.dev>2023-06-05 03:26:22 +0200
commit3ad5633785f7b351bd8a214771dccec5dbac9b12 (patch)
treec8c312cc8714e6067dbd68a6f5c927ff0f8e1a75
parenta6cd20c7db56260f5035e65f1a79c7e28387d3d8 (diff)
community/uhttpmock: upgrade to 0.9.0
-rw-r--r--community/uhttpmock/APKBUILD44
-rw-r--r--community/uhttpmock/only-listen-on-ipv4.patch18
2 files changed, 22 insertions, 40 deletions
diff --git a/community/uhttpmock/APKBUILD b/community/uhttpmock/APKBUILD
index 0f61837c047..29923ee5771 100644
--- a/community/uhttpmock/APKBUILD
+++ b/community/uhttpmock/APKBUILD
@@ -1,39 +1,39 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uhttpmock
-pkgver=0.5.3
-pkgrel=2
+pkgver=0.9.0
+pkgrel=0
pkgdesc="HTTP web service mocking library"
-url="https://gitlab.com/uhttpmock/uhttpmock"
+url="https://gitlab.freedesktop.org/pwithnall/uhttpmock/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="glib-dev libsoup-dev gobject-introspection-dev vala"
+makedepends="
+ glib-dev
+ gobject-introspection-dev
+ libsoup3-dev
+ meson
+ vala
+ "
checkdepends="gsettings-desktop-schemas"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
-source="https://tecnocode.co.uk/downloads/uhttpmock/uhttpmock-$pkgver.tar.xz
- only-listen-on-ipv4.patch"
+subpackages="$pkgname-dev"
+source="https://gitlab.freedesktop.org/pwithnall/uhttpmock/-/archive/$pkgver/uhttpmock-$pkgver.tar.bz2"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --enable-introspection \
- --enable-vala
- make
+ abuild-meson \
+ -Db_lto=true \
+ -Dgtk_doc=false \
+ . output
+ meson compile -C output
}
check() {
- make check
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="9fccdb58ce04c1615d47bafac275c632f161a8148f0af82447286d0017d6b3946145b8a289f9abb55842bf4610ca3e5f2484bf322fb7a33dce42b3ebed45b2ee uhttpmock-0.5.3.tar.xz
-879f12d81b1e83c0e9ff52214b10737576ed4e81af021846d99a4751d00aee378f8af500591e706965f7c5923678eabed91208a1b100dab40d558a8c5ab2172a only-listen-on-ipv4.patch"
+sha512sums="
+5f238b6aee339608000c2b1fb62a62197935555842d335517beb57319f427a618166c29ce67d929199af94ecc5de1a4a0641d049fecc66dcd9b49a5c539fbbf1 uhttpmock-0.9.0.tar.bz2
+"
diff --git a/community/uhttpmock/only-listen-on-ipv4.patch b/community/uhttpmock/only-listen-on-ipv4.patch
deleted file mode 100644
index ebb0ba27a1e..00000000000
--- a/community/uhttpmock/only-listen-on-ipv4.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Upstream: No
-Reason: Docker by default doesn't enable IPv6, so tests using this will fail on
-CI and infra.
-
-diff --git a/libuhttpmock/uhm-server.c b/libuhttpmock/uhm-server.c
-index c28f30a..f1822f6 100644
---- a/libuhttpmock/uhm-server.c
-+++ b/libuhttpmock/uhm-server.c
-@@ -1393,8 +1393,7 @@ uhm_server_run (UhmServer *self)
- g_main_context_push_thread_default (priv->server_context);
-
- priv->server_main_loop = g_main_loop_new (priv->server_context, FALSE);
-- soup_server_listen_local (priv->server, 0, (priv->tls_certificate != NULL) ? SOUP_SERVER_LISTEN_HTTPS : 0,
-- &error);
-+ soup_server_listen_local (priv->server, 0, (priv->tls_certificate != NULL) ? SOUP_SERVER_LISTEN_HTTPS | SOUP_SERVER_LISTEN_IPV4_ONLY :0, &error);
- g_assert_no_error (error); /* binding to localhost should never really fail */
-
- g_main_context_pop_thread_default (priv->server_context);