aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNewbyte <newbie13xd@gmail.com>2023-05-27 16:53:56 +0200
committerpsykose <alice@ayaya.dev>2023-05-27 19:36:54 +0200
commit3b8eb148ad1ccf072c3dd34f94268d722d2b8dd3 (patch)
treeaff3122ca9531477638b62d22314148a42d8ed3e
parent478dbb0802f8e5644f5a655146848954aef4d7f9 (diff)
community/squeekboard: enable LTO
-rw-r--r--community/squeekboard/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/community/squeekboard/APKBUILD b/community/squeekboard/APKBUILD
index e7e6d50e5da..c776b654f01 100644
--- a/community/squeekboard/APKBUILD
+++ b/community/squeekboard/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Ralf Rachinger <alpine@ralfrachinger.de>
pkgname=squeekboard
pkgver=1.22.0
-pkgrel=0
+pkgrel=1
pkgdesc="The final Phosh keyboard"
arch="all !s390x !ppc64le" # fails to build on ppc64le
url="https://gitlab.gnome.org/World/Phosh/squeekboard"
@@ -31,7 +31,10 @@ builddir="$srcdir/$pkgname-v$pkgver"
build() {
- abuild-meson -Dstrict=false . output
+ abuild-meson \
+ -Db_lto=true \
+ -Dstrict=false \
+ . output
meson compile -C output
}