aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-06 09:31:37 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-06 09:32:50 -0300
commit3c980746271de8d0a075b37cd804ea987b588e0a (patch)
treea24aee87abe178f6991b3447345d844aaac614e7
parenta2c03c33dda9917f865314bdfc937dd13ad3397f (diff)
community/py3-automat: re-enable tests but don't run ones for Twisted
Twisted is used for a subsection of functionality and cause a circular dependency since Twisted uses automat as well, Graphviz is also removed since it is the other dependency required for the same subsect of functionality so no reason to keep it if we are going to disable testing it. This was found during the Python3.8 rebuild.
-rw-r--r--community/py3-automat/APKBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/community/py3-automat/APKBUILD b/community/py3-automat/APKBUILD
index ffb0eb4b3ff..8285c5413c2 100644
--- a/community/py3-automat/APKBUILD
+++ b/community/py3-automat/APKBUILD
@@ -6,13 +6,12 @@ _pkgname=Automat
pkgver=0.8.0
pkgrel=1
pkgdesc="Self-service finite-state machines for the programmer on the go"
-options="!check" # Circular dep with py3-twisted
url="https://automat.readthedocs.io/"
arch="noarch"
license="MIT"
depends="py3-attrs py3-six"
makedepends="py3-setuptools"
-checkdepends="py3-graphviz py3-twisted py3-pytest"
+checkdepends="py3-pytest py3-pluggy"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"